zoukankan      html  css  js  c++  java
  • [ACM] poj 2484 A Funny Game(对称博弈)

    A Funny Game
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 3795   Accepted: 2268

    Description

    Alice and Bob decide to play a funny game. At the beginning of the game they pick n(1 <= n <= 106) coins in a circle, as Figure 1 shows. A move consists in removing one or two adjacent coins, leaving all other coins untouched. At least one coin must be removed. Players alternate moves with Alice starting. The player that removes the last coin wins. (The last player to move wins. If you can't move, you lose.)

    Figure 1

    Note: For n > 3, we use c1, c2, ..., cn to denote the coins clockwise and if Alice remove c2, then c1 and c3 are NOT adjacent! (Because there is an empty place between c1 and c3.)

    Suppose that both Alice and Bob do their best in the game.
    You are to write a program to determine who will finally win the game.

    Input

    There are several test cases. Each test case has only one line, which contains a positive integer n (1 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.

    Output

    For each test case, if Alice win the game,output "Alice", otherwise output "Bob".

    Sample Input

    1
    2
    3
    0
    

    Sample Output

    Alice
    Alice
    Bob

    Source

    POJ Contest,Author:Mathematica@ZSU

    解题思路:

    对于n<=2,先手ALICE必胜。n>3时,无论Alice怎么取,BOB都可以取一定的数目来构造出中心对称,这样BOB一定是最后一次取光的。

    代码:

    #include <iostream>
    using namespace std;
    
    int main()
    {
        int n;
        while(cin>>n&&n)
        {
            if(n>2)
                cout<<"Bob"<<endl;
            else
                cout<<"Alice"<<endl;
        }
        return 0;
    }
    


     

  • 相关阅读:
    VMWare虚拟机下为Ubuntu 12.04.1配置静态IP(NAT方式)
    VMWare虚拟机下为Windows Server 2012配置静态IP(NAT方式)
    Windows 7防火墙阻止了远程桌面连接的解决方法
    Win10系统如何在防火墙里开放端口
    ECharts 定制 label 样式
    目标值柱状图
    echarts中datazoom相关配置
    环形图
    带时间轴的指标监控柱状图
    2020mysql面试题
  • 原文地址:https://www.cnblogs.com/vivider/p/3697667.html
Copyright © 2011-2022 走看看