zoukankan      html  css  js  c++  java
  • Agri-Net(最小生成树)

    Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
    Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
    Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
    The distance between any two farms will not exceed 100,000.
    

    Input

    The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem. 
    

    Output

    For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms. 
    

    Sample Input

    4
    0 4 9 21
    4 0 8 17
    9 8 0 16
    21 17 16 0
    

    Sample Output

    28
    

    思路:
    很直接的prime题,克鲁斯卡尔也可以。
    代码:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cstdlib>
    
    using namespace std;
    
    #define INF 0x3f3f3f3f
    
    int N;
    int map[105][105];
    
    bool book[105];
    int lenth[105]; 
    int Prime()
    {
        memset(book,false,sizeof(book));
        int sum = 0;
        book[0] = true;
        for(int i=1 ; i<N ; i++)
        {
            lenth[i] = map[0][i];
        }
    
        for(int i=1 ; i<N ; i++)
        {
            int min = INF;
            int node;
            for(int j=1 ; j<N ; j++)
            {
                if(book[j] == false && lenth[j]<min)
                {
                    min = lenth[j];
                    node = j;
                }
            }
            sum += min;
            book[node] = true;
            for(int i=1 ; i<N ; i++)
            {
                if(book[i] == false && lenth[i]>map[node][i])
                {
                    lenth[i] = map[node][i];
                }
            }
        }
        return sum;
    }
    
    int main()
    {
        while(cin>>N)
        {
            for(int i=0 ; i<N ; i++)
            {
                for(int j=0 ; j<N ; j++)
                {
                    scanf("%d",&map[i][j]);
                }
            }
            cout<<Prime()<<endl;
        }
    
        return 0;
    }
  • 相关阅读:
    VisionPro 各控件的C#中类库 CogAcqFifoTool(2)
    VisionPro 各控件的C#中类库 CogAcqFifoTool(1)
    C# new的三种用法
    C# as用法
    C# 基类之Environment类
    C#开发的软件在Windows7中出现对路径的访问被拒绝异常
    IDEA创建springboot项目【mas-service】
    .Net Core-ObjectPool
    中介者模式的实现-MediatR
    .NET Core分布式事件总线、分布式事务解决方案:CAP
  • 原文地址:https://www.cnblogs.com/vocaloid01/p/9514181.html
Copyright © 2011-2022 走看看