zoukankan      html  css  js  c++  java
  • PTA——List Leaves

    Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

    Output Specification:

    For each test case, print in one line all the leaves’ indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

    Sample Input:

    8
    1 -
    - -
    0 -
    2 7
    - -
    - -
    5 -
    4 6

    Sample Output:

    4 1 5

    思路:
    给出了节点总数和每个节点的字节点。
    根据给出的信息建出树然后层序便利输出叶子结点就行。

    代码:

    #include <stdio.h>
    #include <stdlib.h>
    #include <string.h>
    
    int board[15][2];
    
    typedef struct Node* node;
    
    int is_digit(char A){
        if(A == '-')return -1;
        return (int)(A-'0'); 
    }
    
    int mark[15];
    
    struct Node {
        int Value;
        node Left;
        node Right;
    };
    
    node NodeCreate(int value){
        node p = (node)malloc(sizeof(struct Node));
        p->Value = value;
        p->Left = NULL;
        p->Right = NULL;
        return p;
    }
    
    void Make(node root){
        int mid = root->Value;
        if(board[mid][0] != -1){
            root->Left = NodeCreate(board[mid][0]);
            Make(root->Left);
        }
        if(board[mid][1] != -1){
            root->Right = NodeCreate(board[mid][1]);
            Make(root->Right);
        }
    }
    
    void Print(node root){//层序便利,忘了英文了。。。 
        node queue[100];
        int head,tail;
        head = tail = 0;
        queue[tail++] = root;
        int t = 1;
        while(head != tail){
            node p = queue[head++];
            int key = 0;
            if(p->Left){
                queue[tail++] = p->Left;
                key++;
            }
            if(p->Right){
                queue[tail++] = p->Right;
                key++;
            }
            if(key == 0){
                if(t){
                    printf("%d",p->Value);
                    t = 0;
                }
                else printf(" %d",p->Value);
            }
        }
    }
    
    int main(){
    
        int N;
        scanf("%d",&N);
        for(int i=0 ; i<N ; i++){
            char A,B;
            getchar();
            scanf("%c %c",&A,&B);
            board[i][0] = is_digit(A);
            if(board[i][0]!=-1)mark[board[i][0]] = 1;
            board[i][1] = is_digit(B);
            if(board[i][1]!=-1)mark[board[i][1]] = 1;
        }
    
        node root;
        for(int i=0 ; i<N ; i++){
            if(mark[i] == 0){
                root = NodeCreate(i);
                break;
            }
        }
    
        Make(root);
        Print(root);
    
        return 0;
    }
  • 相关阅读:
    难以表述的话
    王爽《汇编第二版》实验9
    Delphi 文件操作资料
    根据条件改变cxGrid行与列颜色
    汇编笔记总结 之 跳转
    汇编笔记之三 第一个程序
    汇编笔记之四 包含多个段的程序
    汇编中的数据类型
    FastReport 参数的使用
    Winform:SaveFileDialog使用(数据导出示例)
  • 原文地址:https://www.cnblogs.com/vocaloid01/p/9514188.html
Copyright © 2011-2022 走看看