zoukankan      html  css  js  c++  java
  • Find them, Catch them POJ

    The police office in Tadu City decides to say ends to the chaos, as launch actions to root up
    the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify
     which gang a criminal belongs to. The present question is, given two criminals; do they belong
     to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

    Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at
     least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5)
     messages in sequence, which are in the following two kinds:

    1. D [a] [b]
    where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

    2. A [a] [b]
    where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

    Input:

    The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases.
     Then T cases follow. Each test case begins with a line with two integers N and M, followed by M
    lines each containing one message as described above.


    Output:

    For each message "A [a] [b]" in each case, your program should give the judgment based on the information
     got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

    Sample Input:

    1
    5 5
    A 1 2
    D 1 2
    A 1 2
    D 2 4
    A 1 4

    Sample Output:

    Not sure yet.
    In different gangs.
    In the same gang.

    思路:

    开一个数组来记录每个点跟root的关系,典型的带权并查集。

    代码:

    #include<cstdio>  
    #include<iostream> 
      
    using namespace std;
      
    int p[100005]; 
    int r[100005];  
      
    int Find(int a)
    {  
        if(a == p[a])return a;  
      
        int t = p[a];   
        p[a] = Find(p[a]);  
        r[a] = (r[a]+r[t])%2;   
        return p[a];   
    }  
      
    void Union(int a, int b)  
    {  
        int A = Find(a);   
        int B = Find(b);  
      
        p[A] = B;   
        r[A] = (r[a]+1+r[b])%2;  
    }  
      
    int main()  
    {  
        int T;  
        int N,M;  
        cin>>T;  
        while(T--)  
        {     
      		cin>>N>>M;
    		for(int i=1 ; i<=N ; i++){
    			p[i] = i;
    			r[i] = 0;
    		}  
      
            while(M--)  
            {   
    			char ch;  
    	        int a,b;
    	        getchar();
    			scanf("%c %d %d",&ch,&a,&b);
                if(ch == 'A')  
                {  
                	if(Find(a) != Find(b))cout<<"Not sure yet."<<endl;
                    else   
                    {  
                        if(r[a] != r[b])cout<<"In different gangs."<<endl;  
                        else cout<<"In the same gang."<<endl;  
                    }    
                }  
                else if(ch == 'D')  
                {  
                    Union(a,b);  
                }  
            }  
        }  
        return 0;  
    }  
  • 相关阅读:
    docker 常用命令
    linux 查看服务器序列号
    centos 7 lsof 安装使用
    Jenkins +svn +maven +tomcat+ ansible 自动化批量部署
    nginx 部署前期一定要关闭selinux
    yum 执行不了, 解决方法
    IIS发布网站
    使用TreeView 使用多选功能
    C#类和接口
    关于C#垃圾回收
  • 原文地址:https://www.cnblogs.com/vocaloid01/p/9514280.html
Copyright © 2011-2022 走看看