zoukankan      html  css  js  c++  java
  • Sudoku POJ-2676

    Sudoku is a very simple task. A square table with 9 rows and 9 columns
    is divided to 9 smaller squares 3x3 as shown on the Figure. In some of
    the cells are written decimal digits from 1 to 9. The other cells are
    empty. The goal is to fill the empty cells with decimal digits from 1
    to 9, one digit per cell, in such way that in each row, in each column
    and in each marked 3x3 subsquare, all the digits from 1 to 9 to
    appear. Write a program to solve a given Sudoku-task.

    在这里插入图片描述

    Input
    The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.
    Output
    For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.
    Sample Input
    1
    103000509
    002109400
    000704000
    300502006
    060000050
    700803004
    000401000
    009205800
    804000107
    Sample Output**
    143628579
    572139468
    986754231
    391542786
    468917352
    725863914
    237481695
    619275843
    854396127

    Code:

    #include<iostream>
    #include<cstring>
    using namespace std;
    int a[10][10];
    int temp;
    bool check(int n,int num){
    	for(int j=0;j<9;j++){//判断同一列 
    		int i=n/9;
    		if(a[i][j]==num){
    			return 0;
    		}
    	}
    	for(int i=0;i<9;i++){//判断同一行 
    		int j=n%9;
    		if(a[i][j]==num){
    			return 0;
    		}
    	}
    	int ii=n/9/3*3;
    	int jj=n%9/3*3;
    	for(int i=ii;i<ii+3;i++){//判断小方格 
    		for(int j=jj;j<jj+3;j++){
    			if(a[i][j]==num){
    				return 0;
    			}
    		}
    	}
    	return 1;
    }
    void dfs(int n){//深搜 
    	if(n>=81){
    		temp=1;
    		return ;
    	}
    	//cout<<a[n/9][n%9]<<endl;
    	if(a[n/9][n%9]!=0){
    		dfs(n+1);
    	}
    	else {
    		//cout<<temp<<endl;
    		for(int i=1;i<=9;i++){
    			if(check(n,i)){
    				a[n/9][n%9]=i;
    				dfs(n+1);
    				if(temp==1) return ;
    				a[n/9][n%9]=0;
    			}
    		}
    	}
    	
    }
    int main(){
    	int t;
    	cin>>t;
    	while(t--){
    		temp=0;
    		memset(a,0,sizeof(a));
    		for(int i=0;i<9;i++){
    			for(int j=0;j<9;j++){
    				scanf("%1d",&a[i][j]);//输入格式 
    			}
    		}
    		dfs(0);
    		for(int i=0;i<9;i++){
    			for(int j=0;j<9;j++){
    				cout<<a[i][j];
    			}
    			cout<<endl;
    		}
    	}
    	
    	return 0;
    } 
    
    七月在野,八月在宇,九月在户,十月蟋蟀入我床下
  • 相关阅读:
    Netty应用
    原生JDK网络编程- NIO之Reactor模式
    Kafka入门教程
    Java CAS
    Java读写锁
    遍历map的四种方法
    java selector
    Range Sum Query
    Increasing Triplet Subsequence
    Count Numbers with Unique Digits
  • 原文地址:https://www.cnblogs.com/voids5/p/12695050.html
Copyright © 2011-2022 走看看