zoukankan      html  css  js  c++  java
  • HDU——1325 Is there a tree

    Is there a tree?

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 19   Accepted Submission(s) : 3

    Font: Times New Roman | Verdana | Georgia

    Font Size:  

    Problem Description

    A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 
    There is exactly one node, called the root, to which no directed edges point. 

    Every node except the root has exactly one edge pointing to it. 

    There is a unique sequence of directed edges from the root to each node. 

    For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



    In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not. 

    Input

    The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero. 

    Output

    For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1). 

    Sample Input

    6 8 5 3 5 2 6 4
    5 6 0 0
    8 1 7 3 6 2 8 9 7 5
    7 4 7 8 7 6 0 0
    3 8 6 8 6 4
    5 3 5 6 5 2 0 0
    -1 -1

    Sample Output

    Case 1 is a tree.
    Case 2 is a tree.
    Case 3 is not a tree.

    有向树,恶心!!! 树的节点数等于边数加 1。。。。

    View Code
    #include <stdio.h>
    #define M 100000+1
    int parent[M],flag[M];
    int main()
    {
    int a,b,f,i,n,e,count;
    count
    =1;
    while(1)
    {
    scanf(
    "%d %d",&a,&b);
    if(a<0 && b<0) break;
    f
    =1;
    for(i=1;i<M;i++) {parent[i]=-1;flag[i]=0;}
    e
    = n = 0;
    while(a && b)
    {
    if(!flag[a])
    {
    flag[a]
    =1; n++;
    }
    if(!flag[b])
    {
    flag[b]
    =1; n++;
    }
    e
    ++;
    if(parent[b]==-1)
    parent[b]
    =a;
    else
    {
    f
    =0;break;
    }
    scanf(
    "%d %d",&a,&b);
    }
    while(a && b) { scanf("%d %d",&a,&b);}
    if(f && (n==0 || n==e+1) )
    {
    printf(
    "Case %d is a tree.\n",count);
    }
    else
    {
    printf(
    "Case %d is not a tree.\n",count);
    }
    count
    ++;
    }
    return 0;
    }
  • 相关阅读:
    IDEA2019破解版安装
    Docker (一)安装与基本命令
    js导出PDF
    python入门笔记一安装
    微信内关闭当前页面
    微信一些网页
    内网穿透工具:钉钉HTTP内网穿透使用详解
    html生成二维码,qr
    IDEA无法正常启动(打不开&报错)
    微信测试号
  • 原文地址:https://www.cnblogs.com/vongang/p/2116486.html
Copyright © 2011-2022 走看看