zoukankan      html  css  js  c++  java
  • HDU-1050Moving Tables

    Moving Tables

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


    题目链接

    http://acm.hdu.edu.cn/showproblem.php?pid=1050

     

    Problem Description
    The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 



    The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 



    For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
     
    Input
    The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
     
    Output
    The output should contain the minimum time in minutes to complete the moving, one per line.
     
    Sample Input
    3
    4
    10 20
    30 40
    50 60
    70 80
    2
    1 3
    2 200
    3
    10 100
    20 80
    30 50
     
    Sample Output
    10
    20
    30

     总结

    今天做了三道题,这是第三道。我只想说这个HDU的文档有点毒瘤,明明说的贪心,结果却不是用它做的,一开始自己的想法有问题了,想要将区间左边排序,来求公共区间,结果发现自己做不来。看了网上的思路,是将区间分成数组,重复一次就自增一,就能求了。

    #include<iostream>
    #include<cstdio>
    #include<memory.h>
    using namespace std;
    
    int count1[205];
    
    
    int main()
    {
        int T,n,t,beg,end;
        cin >>T;
        while(T--){
            cin >>n;
            memset(count1,0,sizeof(count1));
            for(int i=0;i<n;i++){
                scanf("%d %d",&beg,&end);
                if(beg>end) {t=beg;beg=end;end=t;}
                for(int j=(beg+1)/2;j<=(end+1)/2;j++)
                    count1[j]++;
            }
            int max=0;
            for(int i=0;i<201;i++)
                if(count1[i]>max) max=count1[i];
            cout <<max*10<<endl;
        }
        return 0;
    }

     

  • 相关阅读:
    print 参数
    note
    action标签的属性说明
    Cannot load JDBC driver class 'oracle.jdbc.driver.OracleDriver'
    润乾报表
    javax.naming.NameNotFoundException: Name ZKING is not bound in this Context 的问题
    Myeclipse2013安装svn插件
    Myeclipse2013的优化设置
    Myeclipse解析.classpath文件
    Struts
  • 原文地址:https://www.cnblogs.com/wangdongkai/p/5272982.html
Copyright © 2011-2022 走看看