zoukankan      html  css  js  c++  java
  • HDU-1051Wooden Sticks

          Wooden Sticks

                              Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                           


    Problem Description
    There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

    (a) The setup time for the first wooden stick is 1 minute. 
    (b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

    You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
     

     

    Input
    The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
     

     

    Output
    The output should contain the minimum setup time in minutes, one per line.
     

     

    Sample Input
    3
    5
    4 9 5 2 2 1 3 5 1 4
    3
    2 2 1 1 2 2
    3
    1 3 2 2 3 1
     

     

    Sample Output
    2
    1
    3
     
    Hint
     
    题解
        标准的贪心,将长度排序,然后进行筛选。自己的问题是排序时没注意到长度相等时重量不同的情形,应该将这种情况同样排序。
     
    代码
    #include<iostream>
    #include<cstdio>
    #include<memory.h>
    using namespace std;
    
    int l[5005],w[5005],flag[5005];
    
    void sort1(int* a,int* b,int n)
    {
        int t;
        for(int i=1;i<=n;i++){
            for(int j=i+1;j<=n;j++){
                if(a[i]>a[j]){
                    t=a[i];
                    a[i]=a[j];
                    a[j]=t;
                    t=b[i];
                    b[i]=b[j];
                    b[j]=t;
                }
                if(a[i]==a[j]){
                    if(b[i]>b[j]){
                        t=a[i];
                        a[i]=a[j];
                        a[j]=t;
                        t=b[i];
                        b[i]=b[j];
                        b[j]=t;
                    }
                }
            }
        }
    }
    
    int main()
    {
        int T,n;
        cin >>T;
        while(T--){
            cin >>n;
            int count1=0;
            memset(flag,0,sizeof(flag));
            for(int i=1;i<=n;i++)
                scanf("%d %d",&l[i],&w[i]);
            sort1(l,w,n);
            //for(int i=1;i<=n;i++) cout <<l[i]<<w[i]<<endl;
            flag[1]=1;
            int beg=1;
            while(beg<=n){
                count1++;
                int i,j,s;
                for(i=beg+1,j=beg,s=1;i<=n;i++){
                    if(flag[i]) continue;
                    if(l[j]<=l[i]&&w[j]<=w[i]){
                        flag[i]=1;
                        j=i;
                    }
                    else {
                        if(s){
                            beg=i;
                            s=0;
                        }
                    }
                }
                if(s) break;
            }
            cout <<count1<<endl;
        }
    }
  • 相关阅读:
    less @import and extend及mixin详解
    Less的guards and argument matching
    LESS嵌套中的Mixins和classes
    bootstrap colorscheme以及theme自动生成
    C# Winform 获得下拉框 选中的值
    C# 后台按键 视频播放器 全屏后无法 触发
    C# 调用win32API 获取进程句柄 有毛用???
    C# 键盘钩子
    C# SqlParameter 使用
    C# 获得星期几
  • 原文地址:https://www.cnblogs.com/wangdongkai/p/5317826.html
Copyright © 2011-2022 走看看