zoukankan      html  css  js  c++  java
  • POJ-1050To the Max

    To the Max

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

    Description

    Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
    As an example, the maximal sub-rectangle of the array: 

    0 -2 -7 0 
    9 2 -6 2 
    -4 1 -4 1 
    -1 8 0 -2 
    is in the lower left corner: 

    9 2 
    -4 1 
    -1 8 
    and has a sum of 15. 

    Input

    The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

    Output

    Output the sum of the maximal sub-rectangle.

    Sample Input

    4
    0 -2 -7 0 9 2 -6 2
    -4 1 -4  1 -1
    
    8  0 -2

    Sample Output

    15

    总结
    虽然做了dp有一段时间了,但感觉还是一脸懵逼,看到这道题时完全没有思路,然后又是各种翻博客,看了半天才明白应该用什么思路,或许我就是一个
    见得多才做的了题的人吧,以前弄奥数也是,很少有自己一次性做出来的新题,我要总结过这些思路后才想到怎么做。总之,在这个题我也学到了许多,
    如何将二维转化为一维,如何求最长子串(请原谅我忘记了o(╯□╰)o)。
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    
    #define inf 0x3f3f3f3f;
    
    int mat[105][105];
    int temp[105];
    int n;
    
    int main()
    {
        int max;
        cin>>n;
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                scanf("%d",&mat[i][j]);
            }
        }
        max=-inf;
        for(int i=1;i<n;i++){
            memset(temp,0,sizeof(temp));
            for(int j=i;j<=n;j++){
                int sum=0,max1=0;
                for(int k=1;k<=n;k++){
                    temp[k]+=mat[j][k];
                    sum+=temp[k];
                    if(sum<0) sum=0;
                    if(sum>max1) max1=sum;
                }
                if(max<max1) max=max1;
            }
        }
        cout <<max<<endl;
        return 0;
    }
     
  • 相关阅读:
    SQL执行效率1
    php经典算法(转载)
    linux自用命令
    vim基本命令
    xampp安装
    BUU-rsa
    z3约束器学习笔记
    面试前夕oi挣扎式复习
    bss上的格式化字符串漏洞
    一、汇编
  • 原文地址:https://www.cnblogs.com/wangdongkai/p/5393753.html
Copyright © 2011-2022 走看看