zoukankan      html  css  js  c++  java
  • HDU 2389 Rain on your Parade (二分匹配)

    Rain on your Parade

    Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 655350/165535 K (Java/Others)

    Description
    You’re giving a party in the garden of your villa by the sea. The party is a huge success, and everyone is here. It’s a warm, sunny evening, and a soothing wind sends fresh, salty air from the sea. The evening is progressing just as you had imagined. It could be the perfect end of a beautiful day.
    But nothing ever is perfect. One of your guests works in weather forecasting. He suddenly yells, “I know that breeze! It means its going to rain heavily in just a few minutes!” Your guests all wear their best dresses and really would not like to get wet, hence they stand terrified when hearing the bad news.
    You have prepared a few umbrellas which can protect a few of your guests. The umbrellas are small, and since your guests are all slightly snobbish, no guest will share an umbrella with other guests. The umbrellas are spread across your (gigantic) garden, just like your guests. To complicate matters even more, some of your guests can’t run as fast as the others.
    Can you help your guests so that as many as possible find an umbrella before it starts to pour? 

    Given the positions and speeds of all your guests, the positions of the umbrellas, and the time until it starts to rain, find out how many of your guests can at most reach an umbrella. Two guests do not want to share an umbrella, however. 
     
    Input
    The input starts with a line containing a single integer, the number of test cases.
    Each test case starts with a line containing the time t in minutes until it will start to rain (1 <=t <= 5). The next line contains the number of guests m (1 <= m <= 3000), followed by m lines containing x- and y-coordinates as well as the speed si in units per minute (1 <= si <= 3000) of the guest as integers, separated by spaces. After the guests, a single line contains n (1 <= n <= 3000), the number of umbrellas, followed by n lines containing the integer coordinates of each umbrella, separated by a space.
    The absolute value of all coordinates is less than 10000.
     
    Output
    For each test case, write a line containing “Scenario #i:”, where i is the number of the test case starting at 1. Then, write a single line that contains the number of guests that can at most reach an umbrella before it starts to rain. Terminate every test case with a blank line.
     
    Sample Input
    2
    1
    2
    1 0 3
    3 0 3
    2
    4 0
    6 0
    1
    2
    1 1 2
    3 3 2
    2
    2 2
    4 4
    Sample Output
    Scenario #1: 2
    Scenario #2: 2
     
    分析:匈牙利算法的dfs实现会超时,改为Hopcroft-Carp算法就可以了。
    #include<stdio.h>
    #include<string.h>
    #include<math.h>
    #include<iostream>
    #include<queue>
    using namespace std;
    /* *********************************************
    二分图匹配(Hopcroft-Carp的算法)。
    初始化:g[][]邻接矩阵
    调用:res=MaxMatch();  Nx,Ny要初始化!!!
    时间复杂大为 O(V^0.5 E)
    
    适用于数据较大的二分匹配
    ********************************************** */
    const int MAXN=3005;
    const int INF=1<<28;
    const double eps = 1e-6;
    int g[MAXN][MAXN],Mx[MAXN],My[MAXN],Nx,Ny;
    int dx[MAXN],dy[MAXN],dis;
    bool vst[MAXN];
    bool searchP()
    {
        queue<int>Q;
        dis=INF;
        memset(dx,-1,sizeof(dx));
        memset(dy,-1,sizeof(dy));
        for(int i=0;i<Nx;i++)
            if(Mx[i]==-1)
            {
                Q.push(i);
                dx[i]=0;
            }
        while(!Q.empty())
        {
            int u=Q.front();
            Q.pop();
            if(dx[u]>dis)  break;
            for(int v=0;v<Ny;v++)
                if(g[u][v]&&dy[v]==-1)
                {
                    dy[v]=dx[u]+1;
                    if(My[v]==-1)  dis=dy[v];
                    else
                    {
                        dx[My[v]]=dy[v]+1;
                        Q.push(My[v]);
                    }
                }
        }
        return dis!=INF;
    }
    bool DFS(int u)
    {
        for(int v=0;v<Ny;v++)
           if(!vst[v]&&g[u][v]&&dy[v]==dx[u]+1)
           {
               vst[v]=1;
               if(My[v]!=-1&&dy[v]==dis) continue;
               if(My[v]==-1||DFS(My[v]))
               {
                   My[v]=u;
                   Mx[u]=v;
                   return 1;
               }
           }
        return 0;
    }
    int MaxMatch()
    {
        int res=0;
        memset(Mx,-1,sizeof(Mx));
        memset(My,-1,sizeof(My));
        while(searchP())
        {
            memset(vst,0,sizeof(vst));
            for(int i=0;i<Nx;i++)
              if(Mx[i]==-1&&DFS(i))  res++;
        }
        return res;
    }
    
    int x[MAXN],y[MAXN],s[MAXN];
    
    long long  getdis(int x1,int y1,int x2,int y2)
    {
        return (long long)(x1-x2)*(x1-x2)+(y1-y2)*(y1-y2);
    }
    
    int main()
    {
        int T;
        int iCase=0;
        scanf("%d",&T);
        int n,m,t;
        int xt,yt;
        while(T--){
            iCase++;
            scanf("%d",&t);
            scanf("%d",&Nx);
            memset(g,0,sizeof(g));
            for(int i=0;i<Nx;i++)
                scanf("%d%d%d",&x[i],&y[i],&s[i]);
            scanf("%d",&Ny);
            for(int i=0;i<Ny;i++){
                scanf("%d%d",&xt,&yt);
                for(int j=0;j<Nx;j++){
                    long long cmp1=(long long)s[j]*t*t*s[j];
                    long long cmp2=getdis(x[j],y[j],xt,yt);
                    if(cmp1>=cmp2) g[j][i]=1;
                }
            }
            printf("Scenario #%d:
    %d
    
    ",iCase,MaxMatch());
        }
        return 0;
    }
  • 相关阅读:
    js获取上一个兄弟元素
    js验证身份证
    github绑定自己的域名
    vue子组件传参给父组件
    vue父组件传参给子组件
    运行vue init webpack vueTest时报错
    运用CSS高斯模糊添加图片加载效果
    分享记录一批免费VIP视频解析接口,不定时更新!
    收藏的一些有意思的CSS加载样式
    一款很好用的页面滚动元素动画插件-AOS.JS
  • 原文地址:https://www.cnblogs.com/wangdongkai/p/5643920.html
Copyright © 2011-2022 走看看