zoukankan      html  css  js  c++  java
  • 1128 N Queens Puzzle (20 分)

    The "eight queens puzzle" is the problem of placing eight chess queens on an 8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general Nqueens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - "Eight queens puzzle".)

    Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (, where Qi​​ is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens' solution.

    8q.jpg 9q.jpg
    Figure 1   Figure 2

    Input Specification:

    Each input file contains several test cases. The first line gives an integer K (1). Then Klines follow, each gives a configuration in the format "Q1​​ Q2​​ ... QN​​", where 4 and it is guaranteed that 1 for all ,. The numbers are separated by spaces.

    Output Specification:

    For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.

    Sample Input:

    4
    8 4 6 8 2 7 1 3 5
    9 4 6 7 2 8 1 9 5 3
    6 1 5 2 6 4 3
    5 1 3 5 2 4
    

    Sample Output:

    YES
    NO
    NO
    YES
    #include<iostream>
    #include<cmath>
    #include<vector>
    using namespace std;
    
    int main(){
        int n,k;
        cin >> k;
        for(int i = 0; i < k; i++){
            cin >> n;
            vector<int> v(n+2);
            bool flag = true;
            for(int j = 1; j <= n; j++){
                cin >> v[j];
                for(int t = 1; t < j; t++){
                    if(v[t] == v[j] || abs(j-t) == abs(v[j] - v[t])){
                        flag = false;
                        break;
                    }
                }
            }
            cout << (flag == true ? "YES
    ":"NO
    ");
        }
        return 0;
    }
  • 相关阅读:
    一个关于状态机的问题
    8位同步码修改变4位同步码
    BT1120时序,可以用于自测用
    欧几理德,扩展欧几里德和模线性方程组。
    "旋转的风车"----windows(GDI)绘图
    草滩小恪的学习链接(汇总版)
    酒鬼随机漫步(一个矢量类)
    小题精炼-----初试C语言
    大二(上)------我欠青春一份疯狂
    HDU 1027 Ignatius and the Princess II(康托逆展开)
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/10453483.html
Copyright © 2011-2022 走看看