zoukankan      html  css  js  c++  java
  • 1044 火星数字 (20 分)

    火星人是以 13 进制计数的:

    • 地球人的 0 被火星人称为 tret。
    • 地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
    • 火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

    例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

    输入格式:

    输入第一行给出一个正整数 N(<),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。

    输出格式:

    对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

    输入样例:

    4
    29
    5
    elo nov
    tam
    

    输出样例:

    hel mar
    may
    115
    13
    #include<cstdio>
    #include<iostream>
    #include<string>
    #include<map>
    using namespace std;
    string unitDigit[13] = {"tret","jan","feb","mar","apr","may","jun","jly","aug","sep","oct","nov","dec"};
    string tenDigit[13] = {"tret","tam","hel","maa","huh","tou","kes","hei","elo","syy", "lok","mer","jou"};
    string numToStr[170];
    map<string,int>strToNum;
    
    void init(){
        for(int i = 0; i < 13; i++){
            numToStr[i] = unitDigit[i];
            strToNum[unitDigit[i]] = i;
            numToStr[i * 13] = tenDigit[i];
            strToNum[tenDigit[i]] = i * 13;
        }
        for(int i = 1; i < 13; i++){
            for(int j = 1; j < 13; j++){
                string str = tenDigit[i] + " " + unitDigit[j];
                numToStr[i * 13 + j] = str;
                strToNum[str] = i * 13 + j;
            }
        }
    }
    
    int main(){
        init();
        int n;
        scanf("%d",&n);
        getchar();
        while(n--){
            string str;
            getline(cin,str);
            if(str[0] >= '0' && str[0] <= '9'){
                int num = 0;
                for(int i = 0; i < str.length(); i++){
                    num = num * 10 + (str[i] - '0');
                }
                cout << numToStr[num] << endl;
            }else{
                cout << strToNum[str] << endl;
            }
        }
        return 0;
    }
  • 相关阅读:
    firefox和ie下面的初始化checkbox
    全球宽带排名出炉 韩国第一中国未入榜(附表)
    逆向查询所有父栏目
    js的点点滴滴
    Treeview绑定数据源 层叠结构数据源的应用
    asp.net读取服务器端文件夹列表
    Treeview绑定数据源 层叠结构数据源的应用(续--完善篇)
    VC数据类型
    jQuery核心文档(翻译中)
    iscroll 下拉刷新,上拉加载
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/10453526.html
Copyright © 2011-2022 走看看