zoukankan      html  css  js  c++  java
  • 1152 Google Recruitment (20 分)

    In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.

    prime.jpg

    The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.

    Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

    Input Specification:

    Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

    Output Specification:

    For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

    Sample Input 1:

    20 5
    23654987725541023819
    

    Sample Output 1:

    49877
    

    Sample Input 2:

    10 3
    2468024680
    

    Sample Output 2:

    404
    
     
    #include<iostream>
    #include<algorithm>
    using namespace std;
    
    bool isPrime(int x){
        if(x <= 1) return false;
        for(int i = 2; i*i <= x; i++){
            if(x % i == 0) return false;
        }
        return true;
    }
    
    int main(){
        int l,k;
        cin >> l >> k;
        string s;
        cin >> s;
        for(int i = 0; i < l - k + 1; i++){
            string str = s.substr(i,k);
            int temp = stoi(str);
            if(isPrime(temp)){
                cout << str;
                return 0;
            }
        }
        cout << "404";
        return 0;
    }
  • 相关阅读:
    +7白盒测试与黑盒测试的定义与区别
    对于逆序数组,,选择排序 和 插入排序 那个更快?
    +1.1向量 链表 数组
    3.2 二十三种设计模式全解析
    3.1软件体系结构风格
    Mysql: 强制走索引:mysql between 日期索引 索引问题-日期索引使用
    php: xampp安装对应的phalcon版本(3.2.2-php5.6):比如redis-php5.6, php_igbinary-5.6
    京东自营,你TM太坑了。
    php:微信公众平台上传多媒体接口 41005错误
    php:如何使用PHP排序, key为字母+数字的数组(多维数组)
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/10458856.html
Copyright © 2011-2022 走看看