zoukankan      html  css  js  c++  java
  • 1152 Google Recruitment (20 分)

    In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.

    prime.jpg

    The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.

    Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

    Input Specification:

    Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

    Output Specification:

    For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

    Sample Input 1:

    20 5
    23654987725541023819
    

    Sample Output 1:

    49877
    

    Sample Input 2:

    10 3
    2468024680
    

    Sample Output 2:

    404
    
     
    #include<iostream>
    #include<algorithm>
    using namespace std;
    
    bool isPrime(int x){
        if(x <= 1) return false;
        for(int i = 2; i*i <= x; i++){
            if(x % i == 0) return false;
        }
        return true;
    }
    
    int main(){
        int l,k;
        cin >> l >> k;
        string s;
        cin >> s;
        for(int i = 0; i < l - k + 1; i++){
            string str = s.substr(i,k);
            int temp = stoi(str);
            if(isPrime(temp)){
                cout << str;
                return 0;
            }
        }
        cout << "404";
        return 0;
    }
  • 相关阅读:
    Ubuntu下speedtest的安装
    Ubuntu下快速安装LAMP server
    用python3.3爬取图片
    用python3.3结合snmpget截取信息
    开源数据库Postgresql的备份和恢复
    vuedraggable 两个不同结构的数组之间拖拽
    MyBatis 使用另一个 mapper 中的 resultMap 和 sql
    怎样处理从后台传来大量数据的分页操作
    doc命令操纵数据库
    (全)Mac中mysql的root账户初始密码忘记解决办法以及更改
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/10458856.html
Copyright © 2011-2022 走看看