zoukankan      html  css  js  c++  java
  • 03-树3 Tree Traversals Again (25 分)

    An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


    Figure 1

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2 lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

    Output Specification:

    For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

    Sample Input:

    6
    Push 1
    Push 2
    Push 3
    Pop
    Pop
    Push 4
    Pop
    Pop
    Push 5
    Push 6
    Pop
    Pop
    

    Sample Output:

    3 4 2 6 5 1
    #include<cstdio>
    #include<cstring>
    #include<stack>
    using namespace std;
    const int maxn = 35;
    struct Node{
        int data;
        Node* lchild;
        Node* rchild;
    };
    
    int pre[maxn],in[maxn];
    int n,num = 0;
    
    Node* createTree(int preL,int preR,int inL,int inR){
        if(preL > preR) return NULL;
        Node* root = new Node;
        root->data = pre[preL];
        int k;
        for(k = inL; k <= inR; k++){
            if(in[k] == pre[preL]) break;
        }
        int numLeft = k - inL;
        root->lchild = createTree(preL+1,preL+numLeft,inL,k-1);
        root->rchild = createTree(preL+numLeft+1,preR,k+1,inR);
        return root;
    }
    
    void postOrder(Node* root){
        if(root == NULL) return;
        postOrder(root->lchild);
        postOrder(root->rchild);
        printf("%d",root->data);
        num++;
        if(num < n) printf(" ");
    }
    
    
    int main(){
        scanf("%d",&n);
        char str[5];
        int x,preIndex = 0,inIndex = 0;
        stack<int> s;
        for(int i = 0; i < 2*n; i++){
            getchar();
            scanf("%s",str);
            if(strcmp(str,"Push") == 0){
                scanf("%d",&x);
                s.push(x);
                pre[preIndex++] = x;
            }else{
                in[inIndex++] = s.top();
                s.pop();
            }
        }
        Node* root = createTree(0,n-1,0,n-1);
        postOrder(root);
        return 0;
    }
  • 相关阅读:
    Quartz.Net 学习随手记之04 构建Windows Service承载服务
    Quartz.Net 学习随手记之03 配置文件
    SQL Server问题之计算机名称更改后无法登陆本地数据库
    SQL Server问题之The remote procedure call failed. [0x800706be]
    跨框架菜单menuG5使用
    DLink 524M经常断线、掉线问题的解决
    MSChart使用导航之开发
    ReSharper制作Template帮助我们快速输入代码
    网站右下角弹出通知效果的制作
    Dell6400拆卸与维护
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/10669756.html
Copyright © 2011-2022 走看看