zoukankan      html  css  js  c++  java
  • 06-图2 Saving James Bond

    This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape -- he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head... Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

    Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

    Input Specification:

    Each input file contains one test case. Each case starts with a line containing two positive integers N (≤ 100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x , y) location of a crocodile. Note that no two crocodiles are staying at the same position.

    Output Specification:

    For each test case, print in a line "Yes" if James can escape, or "No" if not.

    Sample Input 1:

    14 20
    25 -15
    -25 28
    8 49
    29 15
    -35 -2
    5 28
    27 -29
    -8 -28
    -20 -35
    -25 -20
    -13 29
    -30 15
    -35 40
    12 12
    

    Sample Output 1:

    Yes
    

    Sample Input 2:

    4 13
    -12 12
    12 12
    -12 -12
    12 -12
    

    Sample Output 2:

    No

    #include<cstdio>
    #include<cmath>
    #include<cstdlib>
    
    const int maxn = 110;
    const double ISLAND_RADIUS = 15.0/2;
    const double DIS_SAVE = 50;
    
    typedef struct Point
    {
        double x,y;
    }Position;
    
    int n;
    double d;
    Position P[maxn];
    bool vis[maxn] = {0};
    
    void Save007();
    bool FirstJump(int v);
    bool DFS(int v);
    bool Judge(int v);
    bool Jump(int v1,int v2);
    
    int main()
    {
        scanf("%d%lf",&n,&d);
        for (int i = 0; i < n; i++)
        {
            scanf("%lf%lf",&P[i].x,&P[i].y);
        }
        Save007();
        return 0;
    }
    
    void Save007()
    {
        bool isSave = false;
        for (int i = 0; i < n; i++)
        {
            if (!vis[i] && FirstJump(i))
            {
                isSave = DFS(i);
                if (isSave)
                {
                    break;
                }
            }
        }
        
        if (isSave)
        {
            printf("Yes");
        }
        else
        {
            printf("No");
        }
    }
    
    bool FirstJump(int v)
    {
        double x = pow(P[v].x,2);
        double y = pow(P[v].y,2);
        double dis = pow((d+ISLAND_RADIUS),2);
        return x+y <= dis;
    }
    
    bool DFS(int v)
    {
        vis[v] = true;
        bool answer = false;
        
        if (Judge(v))
        {
            return true;
        }
        
        for (int i = 0; i < n; i++)
        {
            if (!vis[i] && Jump(v,i))
            {
                answer = DFS(i);
                if (answer)
                {
                    break;
                }
            }
        }
        return answer;
    }
    
    bool Judge(int v)
    {
        int dis_x = abs(P[v].x) + d ;
        int dis_y = abs(P[v].y) + d;
        return dis_x >= DIS_SAVE || dis_y >= DIS_SAVE;
    }
    
    bool Jump(int v1,int v2)
    {
        int dis_x = pow(P[v1].x - P[v2].x, 2);
        int dis_y = pow(P[v1].y - P[v2].y, 2);
        int dis = pow(d + ISLAND_RADIUS, 2);
        return dis_x + dis_y <= dis;
    }
     
  • 相关阅读:
    InnoSetup 打包代码 检测.netFramework
    PartialView中的页面重定向
    Cocos2dx 学习之引擎介绍
    30个高质量的免费jquery滑块PSD文件
    HBase Shell
    图灵百年诞辰 1912.6.232012.6.23
    常用的数据分页技术及比较
    Cocos2dx学习之windows 7的visual studo 2010开发环境安装
    C#实现简易ajax调用后台方法
    AJAX(Professional ASP.NET MVC 3
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/11785432.html
Copyright © 2011-2022 走看看