zoukankan      html  css  js  c++  java
  • 1027. Colors in Mars (20)

    People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

    Input

    Each input file contains one test case which occupies a line containing the three decimal color values.

    Output

    For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

    Sample Input

    15 43 71
    

    Sample Output

    #123456
    #include<cstdio>
    char radix[14] = {
        '0','1','2','3','4','5','6','7','8','9','A','B','C'
    };  //const int 也通过? 
    
    int main(){
        int r,g,b;
         scanf("%d%d%d",&r,&g,&b);
         printf("#");
         printf("%c%c",radix[r/13],radix[r%13]); //进制转化 
         printf("%c%c",radix[g/13],radix[g%13]); //不能是%d 
         printf("%c%c",radix[b/13],radix[b%13]);
       
     return 0;
    }
  • 相关阅读:
    Vue Supermall蘑菇街API后端接口
    Vue UI库:ElementUI使用教程
    Python操作数据库,读取数据并按照json格式写入json文件
    css 轮播图
    ArcGIS Server密码重置
    JavaScript之箭头函数
    arcgis属性对比
    JavaScript之Promise
    很遥远
    请不要等到四十年后才明白
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/8541540.html
Copyright © 2011-2022 走看看