zoukankan      html  css  js  c++  java
  • 1034. Head of a Gang (30)

    One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threshold, respectively. Then N lines follow, each in the following format:

    Name1 Name2 Time

    where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

    Output Specification:

    For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

    Sample Input 1:

    8 59
    AAA BBB 10
    BBB AAA 20
    AAA CCC 40
    DDD EEE 5
    EEE DDD 70
    FFF GGG 30
    GGG HHH 20
    HHH FFF 10
    

    Sample Output 1:

    2
    AAA 3
    GGG 3
    

    Sample Input 2:

    8 70
    AAA BBB 10
    BBB AAA 20
    AAA CCC 40
    DDD EEE 5
    EEE DDD 70
    FFF GGG 30
    GGG HHH 20
    HHH FFF 10
    

    Sample Output 2:

    0
    #include<iostream>
    #include<map>
    #include<string>
    using namespace std;
    const int maxn = 2020;
    
    map<string,int>stringToint;
    map<string,int>gang;
    map<int,string>intTostring;
    int numPerson = 0;                 //总人数 
    int G[maxn][maxn] = {0},weight[maxn] = {0};//邻接表  边权,点权 
    bool inq[maxn] = {false};
    int n,k;//电话数,阈值 
    
    void DFS(int nowVisit, int &head, int &numMember, int &totalValue){
            numMember++;
            inq[nowVisit] = true;
            if(weight[nowVisit] > weight[head]){
                 head = nowVisit;
            }
            for(int i = 0; i < numPerson; i++){
            if(G[nowVisit][i] > 0){
                totalValue += G[nowVisit][i];   //加边权不加点权 
                G[nowVisit][i] = G[i][nowVisit] = 0;
                if(inq[i] == false){
                    DFS(i,head,numMember,totalValue);
                }
            }
        }
    }
    
    void DFSTrave(){
        for(int i = 0; i < numPerson; i++){
            if(inq[i] == false){
                int head = i,numMember = 0,totalValue = 0;
                DFS(i,head,numMember,totalValue);
                if(numMember > 2&& totalValue > k){
                    gang[intTostring[head]] = numMember; //将head的str 和该gang的人数对应 
                }
            }
        }
    }
    int change(string str){  //将传进来的字符和数字对应 
        if(stringToint.find(str) != stringToint.end()){
            return stringToint[str];
        }else{
            stringToint[str] = numPerson;
            intTostring[numPerson] = str;
            return numPerson++;
        }
    }
    int main(){
        
        string str1,str2;    //以前c语言中输入字符串是以char[maxn]存储 
        int w;               //map中用string,scanf和printf就无法实现输入输出 
                             //需要用iostream格式下的cin和cout 
        cin >> n >> k;
        for(int i = 1; i <= n; i++){
            cin >> str1 >> str2 >> w;
            
            int id1 = change(str1);
            int id2 = change(str2);
            weight[id1] += w;
            weight[id2] += w;
            G[id1][id2] += w;
            G[id2][id1] += w;
        }
        DFSTrave();
        cout << gang.size() << endl;
        map<string,int>::iterator it;
        for(it = gang.begin(); it != gang.end();it++){
            
            cout << it->first << " " << it -> second << endl; 
        }
        return 0;
    }
  • 相关阅读:
    Java开发常用知识点总结
    Net实现阿里云开放云存储服务(OSS)
    KEIL MDK-ARM Version 5.26正式版开发工具下载
    【NXP开发板应用—智能插排】4. PWM驱动
    【NXP开发板应用—智能插排】3.驱动GPIO点亮外接LED
    【NXP开发板应用—智能插排】2.初步解析example之GPI
    【NXP开发板应用—智能插排】1.如何使用scp传输文件
    Keil MDK最新版 5.25介绍及下载地址
    springmvc框架helloword
    单例设计模式
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/8580753.html
Copyright © 2011-2022 走看看