zoukankan      html  css  js  c++  java
  • 1084. Broken Keyboard (20)

    On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

    Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

    Input Specification:

    Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or "_" (representing the space). It is guaranteed that both strings are non-empty.

    Output Specification:

    For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

    Sample Input:

    7_This_is_a_test
    _hs_s_a_es
    

    Sample Output:

    7TI
    #include<cstdio>
    #include<cstring>
    int main(){
        char str1[85],str2[85];
        gets(str1);
        gets(str2);
        bool hashTable[128] = {false};   //ASCII码128位 
        int len1 = strlen(str1);
        int len2 = strlen(str2);
        for(int i = 0; i < len1; i++){
            char b,c;
            int j;
            for(j  = 0; j < len2; j++){
                b = str1[i];
                c = str2[j];
                if(b >= 'a' && b <= 'z') b -= 32;
                if(c >= 'a' && c <= 'z') c -= 32;
                if(b == c) break;
            }
            if(j == len2 && hashTable[b] == false){
                printf("%c",b);
                hashTable[b] = true;
            }
        }
        return 0;
    }
  • 相关阅读:
    Skim设置豆沙绿背景色的方法
    被咬掉一口的苹果标识的快捷键
    删除 Mac OS X 中“打开方式”里重复或无用的程序列表
    Android开发学习笔记1
    新学到的Eclipse快捷键 2个
    Android开发学习笔记2
    Mac下Eclipse的自动补全设置
    Nsight Eclipse关于CUDA程序语法高亮颜色的调整
    Tecpolt for mac
    转载:Nsight颜色设置
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/8644232.html
Copyright © 2011-2022 走看看