zoukankan      html  css  js  c++  java
  • 1048. Find Coins (25)

    Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output "No Solution" instead.

    Sample Input 1:

    8 15
    1 2 8 7 2 4 11 15
    

    Sample Output 1:

    4 11
    

    Sample Input 2:

    7 14
    1 8 7 2 4 11 15
    

    Sample Output 2:

    No Solution
    #include<cstdio>
    const int maxn = 100010;
    int hashTable[maxn] = {0};
    int main(){
        int n,m;
        scanf("%d%d",&n,&m);
        int coin;
        for(int i = 0; i < n; i++){
            scanf("%d",&coin);
            hashTable[coin]++;
        }
        for(int i = 1; i <= m; i++){
        if(hashTable[i] && hashTable[m - i]){
            if(i == m - i && hashTable[i] <= 1){
                continue;
            }
            printf("%d %d",i,m - i);
            return 0;
           }
        }
        printf("No Solution");
        return 0;
    }
    //二分法
    #include<cstdio>
    #include<algorithm>
    using namespace std;
    const int maxn = 100010;
    int A[maxn];
    
    int Bin(int left,int right,int key){
        int mid;
        while(left <= right){
            mid = (left+right)/2;
            if(A[mid] > key) right = mid - 1;
            else if(A[mid] < key) left = mid + 1;
            else return mid;
        }
        return -1;
    }
    
    int main(){
        int n,m,i;
        scanf("%d%d",&n,&m);
        for(i = 0 ; i < n; i++){
            scanf("%d",&A[i]);
        }
        sort(A,A+n);
        for(i = 0 ; i < n; i++){
            int pos = Bin(0,n-1,m-A[i]);
            if(pos != -1 && pos != i){
                printf("%d %d",A[i],A[pos]);
                return 0;
            }
        }
        if(i == n) printf("No Solution");
        return 0;
    }
    //twopointer 
    #include<cstdio>
    #include<algorithm>
    using namespace std;
    const int maxn = 100010;
    int a[maxn];
    
    void twopointer(int n,int m){
        int i = 0, j = n-1;
        while(i < j){
            if(a[i]+a[j] == m) break;
            else if(a[i]+a[j] > m) j--;
            else i++;
        }
        if(i < j) printf("%d %d",a[i],a[j]);
        else printf("No Solution");
    }
    
    int main(){
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i = 0 ; i < n ; i++){
            scanf("%d",&a[i]);
        }
        sort(a,a+n);
        twopointer(n,m);
        return 0;
    }
  • 相关阅读:
    BZOJ 2654: tree
    洛谷P1972[SDOI2009]HH的项链
    洛谷 P3833 [SHOI2012]魔法树
    P2167 [SDOI2009]Bill的挑战
    洛谷 P2145 [JSOI2007]祖码
    洛谷 P4170 [CQOI2007]涂色
    P2024 [NOI2001]食物链
    USACO 2012 December ZQUOJ 24122 Scrambled Letters(二分)
    USACO 2012 December ZQUOJ 24128 Wifi Setup(动态dp)
    2013长春网赛1009 hdu 4767 Bell(矩阵快速幂+中国剩余定理)
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/8655324.html
Copyright © 2011-2022 走看看