zoukankan      html  css  js  c++  java
  • 1037. Magic Coupon (25)

    The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

    For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

    Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

    Output Specification:

    For each test case, simply print in a line the maximum amount of money you can get back.

    Sample Input:

    4
    1 2 4 -1
    4
    7 6 -2 -3
    

    Sample Output:

    43
    //有一个测试点没过
    #include<cstdio>
    #include<algorithm>
    using namespace std;
    
    int main(){
        int n,m;
        int coupon[100010],product[100010];
        scanf("%d",&n);
        for(int i = 0; i < n; i++){
            scanf("%d",&coupon[i]);
        }
        scanf("%d",&m);
        for(int i = 0; i < m; i++){
            scanf("%d",&product[i]);
        }
        sort(coupon,coupon+n);
        sort(product,product+m);
        int ans = 0;
        for(int i = 0;coupon[i] < 0&& product[i] < 0&& i < n&&i < m;i++){
            ans+=coupon[i]*product[i];
        }
        for(int i=n-1,j=m-1;coupon[i] > 0&& product[i] >0&&i >= 0&& j >= 0;i--,j--){   //product【j】
            ans+=coupon[i]*product[j];
        }
        printf("%d",ans);
        return 0;
    }
    #include<cstdio>
    #include<algorithm>
    using namespace std;
    
    int main(){
        int n,m;
        int coupon[100010],product[100010];
        scanf("%d",&n);
        for(int i = 0; i < n; i++){
            scanf("%d",&coupon[i]);
        }
        scanf("%d",&m);
        for(int i = 0; i < m; i++){
            scanf("%d",&product[i]);
        }
        sort(coupon,coupon+n);
        sort(product,product+m);
        int i = 0,j, ans = 0;
        while(i < n && i < m && coupon[i] < 0 && product[i] < 0){
            ans += coupon[i]*product[i];
            i++;
        }
        i = n - 1;
        j = m - 1;
        while(i >= 0 && j >= 0 && coupon[i] > 0 && product[j] > 0){
            ans += coupon[i] * product[j];
            i--;
            j--;
        }
        printf("%d",ans);
        return 0;
    }
  • 相关阅读:
    12_springmvc拦截器
    11_springmvc之RESTful支持
    10_springmvc JSON数据交互
    09_springmvc图片上传
    09_springmvc异常处理
    08_springmvc数据回显和@ModelAttribute注解详解
    Eclipse-----解决调试源码不进入断点问题
    JavaScript-----截取字符串的常用方法
    排序(Sort)-----冒泡排序
    SpringMVC探究-----常用获取传递参数的方法
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/8662437.html
Copyright © 2011-2022 走看看