zoukankan      html  css  js  c++  java
  • 1038. Recover the Smallest Number (30)

    Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

    Input Specification:

    Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the smallest number in one line. Do not output leading zeros.

    Sample Input:

    5 32 321 3214 0229 87
    

    Sample Output:

    22932132143287
    #include<cstdio>
    #include<string>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    bool cmp(string a, string b){
        return a + b < b + a;
    }
    string str[100010];
    int main(){
        int n;
        cin >> n;
        for(int i = 0; i < n; i++){
            cin >> str[i];
        } 
        sort(str,str+n,cmp);
        string ans;
        for(int i = 0; i < n; i++){
            ans += str[i];
        } 
        while(ans.size() != 0 && ans[0] == '0'){
            ans.erase(ans.begin());
        }
        if(ans.size() == 0) cout << 0;
        else cout << ans;
    }
  • 相关阅读:
    Git标签使用技巧
    Git入门基本概述
    过滤器+缓存在.NET5WebApi项目中的简单使用
    在.NET5中 使用JWT鉴权授权
    Git常用开发命令
    时间戳的实际使用
    两个日期字段相减,进行计算
    MQ的理论理解
    第一周学习C语言的总结!
    问题(the question)
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/8668950.html
Copyright © 2011-2022 走看看