zoukankan      html  css  js  c++  java
  • 1078. Hashing (25)

    The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be "H(key) = key % TSize" where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

    Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (<=104) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

    Sample Input:

    4 4
    10 6 4 15
    

    Sample Output:

    0 1 4 -
    #include<cstdio>
    #include<cmath>
    const int maxn = 10010;
    
    bool isPrime(int x){
        if(x <= 1) return false;
        int sqr = (int)sqrt(1.0*x);
        for(int i = 2; i <= sqr; i++){
            if(x % i == 0) return false;
        }
        return true;
    }
    
    bool HashTable[maxn] = {0};
    int main(){
        int Msize,n,a;
        scanf("%d%d",&Msize,&n);
        while(isPrime(Msize) == false) Msize++;
        for(int i = 0; i < n; i++){
            scanf("%d",&a);
            int m = a % Msize;
            if(HashTable[m] == false){
                HashTable[m] = true;
                if(i == 0) printf("%d",m);
                else printf(" %d",m);
            }else{
                int step;
                for(step = 1; step <= Msize; step++){
                    int m = (a+step*step)%Msize;
                    if(HashTable[m] == false){
                        HashTable[m] = true;
                        if(i == 0) printf("%d",m);
                        else printf(" %d",m);
                        break;
                    }
                }
                if(step >= Msize){
                    if(i > 0)printf(" ");
                    printf("-");
                    
                }
            }
        }
        return 0;
    }
  • 相关阅读:
    【CODEVS1287】矩阵乘法
    云时代架构读后感(十五)
    使用js拆分带参数的URL,将参数分离出来
    云时代架构读后感(十四)
    云时代架构读后感(十三)
    SSH框架整合报错org.springframework.web.context.ContextLoaderListener
    SOA架构分析
    云时代架构读后感(十二)
    Hibernate的CRUD配置及简单使用
    Struct2的简单的CRUD配置和使用
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/8877159.html
Copyright © 2011-2022 走看看