zoukankan      html  css  js  c++  java
  • 1008 Elevator (20)

    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

    Output Specification:

    For each test case, print the total time on a single line.

    Sample Input:

    3 2 3 1
    

    Sample Output:

    41
    #include<cstdio>
    int main(){
        int n,k,f = 0, sum = 0;
        scanf("%d",&n);
        for(int i = 0; i < n; i++){
            scanf("%d",&k);
            if(k > f){
                sum += (k-f)*6+5;
                f = k;
            }else{
                sum += (f-k)*4+5;
                f= k;
            }
        }
        printf("%d",sum);
        return 0;
    } 

     20190718

    #include<cstdio>
    
    int main()
    {
         int curr = 0;
        int k;
        int next;
        scanf("%d",&k);
        int sum = 0;
        for(int i = 0; i < k; i++)
        {
             scanf("%d",&next);
            if(next > curr)
            {
                 sum += (next - curr) * 6 + 5;    
            }    
            else
            {
                sum += (curr - next) * 4 + 5;
            }
            curr = next;
        }    
        printf("%d",sum);
        return 0;
    } 
  • 相关阅读:
    Canvas基础讲义
    封装一个DivTag
    递归深拷贝
    构造函数的执行过程
    封装一个Ajax工具函数
    数组去重
    [js开源组件开发]js多选日期控件
    自己写的表格插件autotable
    复杂表格的树形结构的添加删除行div实现
    自制html5塔防游戏
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/9400576.html
Copyright © 2011-2022 走看看