zoukankan      html  css  js  c++  java
  • 1017 Queueing at Bank (25)

    Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

    Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

    Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

    Output Specification:

    For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

    Sample Input:

    7 3
    07:55:00 16
    17:00:01 2
    07:59:59 15
    08:01:00 60
    08:00:00 30
    08:00:02 2
    08:03:00 10

    Sample Output:

    8.2

    #include<cstdio>
    #include<algorithm>
    #include<vector>
    using namespace std;
    const int maxn = 111;
    const int INF = 1000000000; 
    struct Customer{
        int comeTime,serveTime;
    }newCustomer;
    vector<Customer> custom;
    
    int convert(int h,int m,int s){
        return h*3600+m*60+s;
    }
    
    bool cmp(Customer a,Customer b){
        return a.comeTime < b.comeTime;
    }
    
    int endTime[maxn];
    int main(){
        int n,k,totTime = 0;
        scanf("%d%d",&n,&k);
        int stTime = convert(8,0,0);
        int edTime = convert(17,0,0);
        for(int i = 0; i < k; i++) endTime[i] = stTime;
        for(int i = 0; i < n; i++){
            int h,m,s,serveTime;
            scanf("%d:%d:%d%d",&h,&m,&s,&serveTime);
            int comeTime = convert(h,m,s);
            if(comeTime > edTime) continue;
            newCustomer.comeTime = comeTime;
            newCustomer.serveTime = serveTime <= 60 ? serveTime * 60 : 3600;
            custom.push_back(newCustomer);
        }
        sort(custom.begin(),custom.end(),cmp);
        for(int i = 0; i < custom.size(); i++){
            int idx = -1, minEndTime = INF;
            for(int j = 0 ; j < k ; j++){
                if(endTime[j] < minEndTime){
                    idx = j;
                    minEndTime = endTime[j];
                }
            }
            if(endTime[idx] <= custom[i].comeTime){
                endTime[idx] = custom[i].comeTime + custom[i].serveTime;
            }else{
                totTime += (endTime[idx] - custom[i].comeTime);
                endTime[idx] += custom[i].serveTime;
            }
        }
        if(custom.size() == 0) printf("0.0");
        else printf("%.1f",totTime/60.0/custom.size());
        return 0;
    }
  • 相关阅读:
    css3360度旋转动画
    PAT 1084 外观数列(20)(代码+思路+推荐测试用例)
    PAT 1083 是否存在相等的差(20)(代码+思路)
    PAT 1082 射击比赛(20)(代码+思路)
    PAT 1079 延迟的回文数(代码+思路)
    PAT 1078 字符串压缩与解压(20)(代码+思路)
    PAT 1077 互评成绩计算(20)(代码+思路)
    PAT 1073 多选题常见计分法(20)(代码+思路)
    PAT 1072 开学寄语(20)(代码+思路)
    PAT 1069 微博转发抽奖(20)(代码+思路+测试点4)
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/9439512.html
Copyright © 2011-2022 走看看