zoukankan      html  css  js  c++  java
  • 07-图6 旅游规划 (25 分)

    有了一张自驾旅游路线图,你会知道城市间的高速公路长度、以及该公路要收取的过路费。现在需要你写一个程序,帮助前来咨询的游客找一条出发地和目的地之间的最短路径。如果有若干条路径都是最短的,那么需要输出最便宜的一条路径。

    输入格式:

    输入说明:输入数据的第1行给出4个正整数N、M、S、D,其中N(2)是城市的个数,顺便假设城市的编号为0~(N1);M是高速公路的条数;S是出发地的城市编号;D是目的地的城市编号。随后的M行中,每行给出一条高速公路的信息,分别是:城市1、城市2、高速公路长度、收费额,中间用空格分开,数字均为整数且不超过500。输入保证解的存在。

    输出格式:

    在一行里输出路径的长度和收费总额,数字间以空格分隔,输出结尾不能有多余空格。

    输入样例:

    4 5 0 3
    0 1 1 20
    1 3 2 30
    0 3 4 10
    0 2 2 20
    2 3 1 20
    

    输出样例:

    3 40
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    const int maxn = 510;
    const int INF = 1000000000;
    int G[maxn][maxn],cost[maxn][maxn];
    int d[maxn],c[maxn];
    bool vis[maxn] = {false};
    int n,m,st,ed;
    
    void Dijkstra(int s){
        fill(d,d+maxn,INF);
        fill(c,c+maxn,INF);
        d[s] = 0;
        c[s] = 0;
        for(int i = 0; i < n; i++){
            int u = -1, min = INF;
            for(int j = 0; j < n; j++){
                if(vis[j] == false && d[j] < min){
                    u = j;
                    min = d[j];
                }
            }
            if(u == -1) return;
            vis[u] = true;
            for(int v = 0; v < n; v++){
                if(vis[v] == false && G[u][v] != INF){
                    if(d[v] > d[u] + G[u][v]){
                        d[v] = d[u] + G[u][v];
                        c[v] = c[u] + cost[u][v];
                    }else if(d[v] == d[u] + G[u][v]){
                        if(c[v] > c[u] + cost[u][v]){
                            c[v] = c[u] + cost[u][v];
                        }
                    }
                }
            }
        }
    }
    
    int main(){
        scanf("%d%d%d%d",&n,&m,&st,&ed);
        fill(G[0],G[0]+maxn*maxn,INF);
        //fill(cost[0],cost[0]+maxn*maxn,INF);
        int u,v;
        for(int i = 0; i < m; i++){
            scanf("%d%d",&u,&v);
            scanf("%d%d",&G[u][v],&cost[u][v]);
            G[v][u] = G[u][v];
            cost[v][u] = cost[u][v];
        } 
        Dijkstra(st);
        printf("%d %d",d[ed],c[ed]);
        return 0;
    }
  • 相关阅读:
    MSDTC服务出错
    jquery.lazyload.js实现图片延迟加载——wordpress图片随滚动条渐显效果
    js:警惕firstChild
    基于jquery的表格排序
    jquery JSON的解析方式
    用JS jquery取float型小数点后两位
    JQuery之append和appendTo的区别,还有js中的appendChild用法
    js笔记之Math random()、ceil()、floor()、round()
    Oracle笔记
    STL: equal
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/9979054.html
Copyright © 2011-2022 走看看