zoukankan      html  css  js  c++  java
  • 08-图8 How Long Does It Take (25 分

    Given the relations of all the activities of a project, you are supposed to find the earliest completion time of the project.

    Input Specification:

    Each input file contains one test case. Each case starts with a line containing two positive integers N (≤), the number of activity check points (hence it is assumed that the check points are numbered from 0 to N1), and M, the number of activities. Then M lines follow, each gives the description of an activity. For the i-th activity, three non-negative numbers are given: S[i]E[i], and L[i], where S[i] is the index of the starting check point, E[i] of the ending check point, and L[i]the lasting time of the activity. The numbers in a line are separated by a space.

    Output Specification:

    For each test case, if the scheduling is possible, print in a line its earliest completion time; or simply output "Impossible".

    Sample Input 1:

    9 12
    0 1 6
    0 2 4
    0 3 5
    1 4 1
    2 4 1
    3 5 2
    5 4 0
    4 6 9
    4 7 7
    5 7 4
    6 8 2
    7 8 4
    

    Sample Output 1:

    18
    

    Sample Input 2:

    4 5
    0 1 1
    0 2 2
    2 1 3
    1 3 4
    3 2 5
    

    Sample Output 2:

    Impossible
    #include<cstdio>
    #include<queue>
    using namespace std;
    const int maxn = 110;
    int map[maxn][maxn],d[maxn],indegree[maxn];
    int main(){
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i = 0; i < n; i++){
            d[i] = -1;
            indegree[i] = 0;
            for(int j = 0; j < n; j++){
                map[i][j] = map[j][i] = -1;
            }
        }
        int u,v,w;
        for(int i = 0; i < m; i++){
            scanf("%d%d%d",&u,&v,&w);
            map[u][v] = w;
            indegree[v]++;
        }
        queue<int> q;
        for(int i = 0; i < n; i++){
            if(!indegree[i]){
                q.push(i);
                d[i] = 0;
            }
        }
        int cur;
        while(!q.empty()){
            cur = q.front();
            q.pop();
            for(int i = 0; i < n; i++){
                if(map[cur][i] != -1){
                    indegree[i]--;
                    if(d[cur] + map[cur][i] > d[i]){
                        d[i] = d[cur] + map[cur][i];
                    }
                    if(!indegree[i]){
                        q.push(i);
                    }
                }
            }
        }
        int maxCost = -1;
        int i;
        for(i = 0 ; i < n; i++){
            if(indegree[i]) break;
            if(d[i] > maxCost) maxCost = d[i];
        }
        if(i == n) printf("%d",maxCost);
        else printf("Impossible");
        return 0;
    }
  • 相关阅读:
    ajax提交json数据到后端C#解析
    icheck判断是否选中
    sql多列值一行显示
    IDEA 2018 搭建 Spring MVC helloworld
    C# 注册DLL至GAC 并在添加引用中使用该DLL
    Java获取执行进程的dump文件及获取Java stack
    intellij idea搭建SpringBoot
    通过链接跳转登录到另外一个系统
    访问Hsql .data数据库文件
    基于weui的城市选择器(city-picker)
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/9985071.html
Copyright © 2011-2022 走看看