Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input
1 100
Sample Output
1 5050
代码如下:
#include<stdio.h>
int main()
{
int n,m;
while(scanf("%d",&n)!=EOF)
{
if(n%2==0)
m=n/2*(n+1);
else
m=(n+1)/2*n;
printf("%d ",sum);
}
return 0;
}
int main()
{
int n,m;
while(scanf("%d",&n)!=EOF)
{
if(n%2==0)
m=n/2*(n+1);
else
m=(n+1)/2*n;
printf("%d ",sum);
}
return 0;
}
之前我没考虑奇偶问题,一直过不了。