zoukankan      html  css  js  c++  java
  • Encoding http://acm.hdu.edu.cn/showproblem.php?pid=1020

    Encoding

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 21463    Accepted Submission(s): 9352

    Problem Description
    Given a string containing only 'A' - 'Z', we could encode it using the following method: 
    1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.
    2. If the length of the sub-string is 1, '1' should be ignored.
     
    Input
    The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
     
    Output
    For each test case, output the encoded string in a line.
     
    Sample Input
    2 ABC ABBCCC
     
    Sample Output
    ABC A2B3C
     
    Author
    ZHANG Zheng
     
    Recommend
    JGShining
     
     
     
     
    #include<stdio.h>
    #include<string.h>
    #define M 10000
    int main()
    {
        int n;
        char a[M+10];
        scanf("%d",&n);
        {
            while(n--)
            {
                int i,j,l,k=0;
                getchar();
                scanf("%s",a);
                l=strlen(a);
                for(i=0;i<l;i++)
                {
                    if(a[i]==a[i+1])
                        a[i]=0;
                }
                for(i=0;i<l;i++)
                {
                    if(a[i]==0)
                        k++;
                    else
                    {
                        if(k==0)
                            printf("%c",a[i]);
                        else
                            printf("%d%c",k+1,a[i]);
                        k=0;
                    }
                }
                printf(" ");
            }
        }
        return 0;
    }
    此题的k是连续字母的的个数。
    代码如下:
     
  • 相关阅读:
    【整理】uclibc,eglibc,glibc之间的区别和联系
    C语言calloc()函数:分配内存空间并初始化——stm32中的应用
    收藏!了解UART总线工作原理看这一篇就够了!
    在stm32开发可以调用c标准库的排序和查找 qsort bsearch
    更少的直接百度,更多的取看API
    Sping中的IOC四种注解的简单记录
    使用for循环还是foreach循环?
    总是要还的
    EL表达式,保留小数点后两位
    如何遍历二叉树
  • 原文地址:https://www.cnblogs.com/wangyouxuan/p/3235211.html
Copyright © 2011-2022 走看看