zoukankan      html  css  js  c++  java
  • (最大生成树) poj 1979

    Heavy Transportation
    Time Limit: 3000MS   Memory Limit: 30000K
    Total Submissions: 22556   Accepted: 5987

    Description

    Background 
    Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
    Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

    Problem 
    You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

    Input

    The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

    Output

    The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

    Sample Input

    1
    3 3
    1 2 3
    1 3 4
    2 3 5
    

    Sample Output

    Scenario #1:
    4
    

    Source

    TUD Programming Contest 2004, Darmstadt, Germany
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<string>
    #include<cmath>
    #include<cstdlib>
    #include<algorithm>
    using namespace std;
    int n,fa[1010],m;
    int find(int x)
    {
        return x==fa[x]?x:fa[x]=find(fa[x]);
    }
    struct node
    {
        int x,y,w;
    }e[1000010];
    bool cmp(node a,node b)
    {
        return a.w>b.w;
    }
    int main()
    {
        int tt,cas=1;
        scanf("%d",&tt);
        while(tt--)
        {
            int ans=0;
            scanf("%d%d",&n,&m);
            for(int i=1;i<=n;i++)
                fa[i]=i;
            for(int i=1;i<=m;i++)
            {
                scanf("%d%d%d",&e[i].x,&e[i].y,&e[i].w);
            }
            sort(e+1,e+1+m,cmp);
            for(int i=1;i<=m;i++)
            {
                int fx,fy;
                fx=find(e[i].x),fy=find(e[i].y);
                if(fx!=fy)
                {
                    fa[fx]=fy;
                    ans=e[i].w;
                    if(find(1)==find(n))
                        break;
                }
            }
            printf("Scenario #%d:
    %d
    
    ",cas++,ans);
        }
        return 0;
    }
    

      

  • 相关阅读:
    Redis&PHP的使用安装-windows版
    【JAVA】使用Eclipse依赖生成jar包时,避免最外层同时生成资源文件的配置。
    【ActiveMQ】重写监听
    【ActiveMQ】设置自动重连
    【ActiveMQ】持久化消息队列的三种方式
    【Spring】手动获取spring容器对象时,报no qualifying bean of type is defined
    【监控】使用probe对tomcat服务进行监控
    【前端】使用weinre对手机、微信浏览器页面调试
    【前端】一句命令快速合并压缩 JS、CSS
    【前端】CSS雪碧
  • 原文地址:https://www.cnblogs.com/water-full/p/4527145.html
Copyright © 2011-2022 走看看