zoukankan      html  css  js  c++  java
  • Oil Deposits -----HDU1241暑假集训-搜索进阶

    L - Oil Deposits
    Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
    Submit Status

    Description

    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
     

    Input

    The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
     

    Output

    For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
     

    Sample Input

    1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
     

    Sample Output

    0 1 2 2

    #include <iostream>
    #include <cstdlib>
    #include <cstdio>
    #include <algorithm>
    #include <vector>
    #include <queue>
    #include <cmath>
    #include <cstring>
    using namespace std;
    #define INF 0xfffffff
    #define maxn 15

    char maps[maxn][maxn];
    int m, n;
    int dir[8][2] = { {-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1} };

    void DFS(int x,int y)
    {
    maps[x][y] = '*';

    for(int i=0; i<8; i++)
    {
    int nx = x + dir[i][0];
    int ny = y + dir[i][1];

    if(nx >= 0 && nx < m && ny >= 0 && ny < n && maps[nx][ny] == '@')
    DFS(nx, ny);
    }
    }

    int main()
    {
    int ans;
    while(cin >> m >> n, m+n)
    {
    ans = 0;
    for(int i=0; i<m; i++)
    cin >> maps[i];

    for(i=0; i<m; i++)
    {
    for(int j=0; j<n; j++)
    {
    if(maps[i][j] == '@')
    {
    ans ++;
    DFS(i, j);
    }
    }
    }
    cout << ans << endl;
    }
    return 0;
    }

  • 相关阅读:
    DbUtils类的添加,修改,删除
    QueryRunner类的八种结果处理集
    中国传统文化---------斗地主----------
    剑指Offer42 左旋字符串
    剑指Offer41 反转单词顺序,单词字符顺序不变
    剑指Offer40 和为s的连续正数序列
    剑指Offer39 数组中寻找和为sum的两个数字
    剑指Offer36 数字在排序数组中出现的次数
    剑指Offer37 二叉树深度与平衡二叉树判断
    剑指Offer38 数组所有数字出现两次,只有两个出现了一次,找出这两个数字
  • 原文地址:https://www.cnblogs.com/wazqWAZQ1/p/4651430.html
Copyright © 2011-2022 走看看