zoukankan      html  css  js  c++  java
  • HDOJ/HDU 2163 Palindromes(判断回文串~)

    Problem Description
    Write a program to determine whether a word is a palindrome. A palindrome is a sequence of characters that is identical to the string when the characters are placed in reverse order. For example, the following strings are palindromes: “ABCCBA”, “A”, and “AMA”. The following strings are not palindromes: “HELLO”, “ABAB” and “PPA”.

    Input
    The input file will consist of up to 100 lines, where each line contains at least 1 and at most 52 characters. Your program should stop processing the input when the input string equals “STOP”. You may assume that input file consists of exclusively uppercase letters; no lowercase letters, punctuation marks, digits, or whitespace will be included within each word.

    Output
    A single line of output should be generated for each string. The line should include “#”, followed by the problem number, followed by a colon and a space, followed by the string “YES” or “NO”.

    Sample Input
    ABCCBA
    A
    HELLO
    ABAB
    AMA
    ABAB
    PPA
    STOP

    Sample Output

    #1: YES
    #2: YES
    #3: NO
    #4: NO
    #5: YES
    #6: NO
    #7: NO


    就是简单的判断回文串的问题,遇到STOP结束程序。

    import java.util.Scanner;
    
    /**
     * @author 陈浩翔
     * 2016-6-5
     */
    public class Main{
    
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            int t =1;
            while(sc.hasNext()){
                String str =sc.next();
                if("STOP".equals(str)){
                    return;
                }
                System.out.print("#"+(t++)+": ");
                boolean isProgram = true;
                for(int i=0,j=str.length()-1;i<j;i++,j--){
                    if(str.charAt(i)!=str.charAt(j)){
                        isProgram=false;
                        break;
                    }
                }
                if(isProgram){
                    System.out.println("YES");
                }else{
                    System.out.println("NO");
                }
    
            }
        }
    }
    
  • 相关阅读:
    linux工具-awk
    linux工具-sed
    linux工具-grep
    linux编程-bash
    linux命令-sort
    linux命令-seq
    linux命令-find
    linux命令-split
    IDEA去除xml文件中的屎黄色背景
    Rabbit 基于cloud 的配置使用结构流程
  • 原文地址:https://www.cnblogs.com/webmen/p/5739139.html
Copyright © 2011-2022 走看看