zoukankan      html  css  js  c++  java
  • HDOJ/HDU 1200 To and Fro(加密解密字符串)

    Problem Description
    Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is “There’s no place like home on a snowy night” and there are five columns, Mo would write down

    t o i o y
    h p k n n
    e l e a i
    r a h s g
    e c o n h
    s e m o t
    n l e w x

    Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character ‘x’ to pad the message out to make a rectangle, although he could have used any letter.

    Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as

    toioynnkpheleaigshareconhtomesnlewx

    Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.

    Input
    There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2… 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.

    Output
    Each input set should generate one line of output, giving the original plaintext message, with no spaces.

    Sample Input
    5
    toioynnkpheleaigshareconhtomesnlewx
    3
    ttyohhieneesiaabss
    0

    Sample Output
    theresnoplacelikehomeonasnowynightx
    thisistheeasyoneab

    水题。
    译码还原问题

    题目保证输入的数据一定是一个矩形的。

    import java.util.Scanner;
    
    public class Main{
    
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            while(sc.hasNext()){
                int n=sc.nextInt();
                if(n==0){
                    return;
                }
                String str=sc.next();
                String s[] = new String[str.length()/n];
                for(int i=0;i<str.length()/n;i++){
                    s[i]="";//不要忘记初始化
                    if(i%2==0){
                        for(int k=i*n;k<n+n*i;k++){
                            s[i]=s[i]+str.charAt(k);
                        }
                    }else{
                        for(int k=i*n;k<n+n*i;k++){
                            s[i]=str.charAt(k)+s[i];
                        }
                    }
                    //System.out.println(s[i]);
                }
    
                for(int i=0;i<n;i++){
                    for(int k=0;k<s.length;k++){
                        System.out.print(s[k].charAt(i));
                    }
                }
                System.out.println();
    
            }
    
        }
    
    }
    
  • 相关阅读:
    【题解】Killer Names($O(nlog n)$做法)
    【瞎讲】类欧几里得入土教程
    【题解】SDOI2010所驼门王的宝藏(强连通分量+优化建图)
    【题解】ARC101F Robots and Exits(DP转格路+树状数组优化DP)
    【题解】LOJ6060 Set(线性基)
    【题解】CF1056F Write the Contest(三分+贪心+DP)
    【题解】多少个$1$(exBSGS)
    【题解】幼儿园篮球题(范德蒙德卷积+斯特林+NTT)
    【题解】P1373 小a和uim之大逃离
    【题解】地精部落(DP)
  • 原文地址:https://www.cnblogs.com/webmen/p/5739151.html
Copyright © 2011-2022 走看看