zoukankan      html  css  js  c++  java
  • HDOJ(HDU) 2317 Nasty Hacks(比较、)

    Problem Description
    You are the CEO of Nasty Hacks Inc., a company that creates small pieces of malicious software which teenagers may use
    to fool their friends. The company has just finished their first product and it is time to sell it. You want to make as much money as possible and consider advertising in order to increase sales. You get an analyst to predict the expected revenue, both with and without advertising. You now want to make a decision as to whether you should advertise or not, given the expected revenues.

    Input
    The input consists of n cases, and the first line consists of one positive integer giving n. The next n lines each contain 3 integers, r, e and c. The first, r, is the expected revenue if you do not advertise, the second, e, is the expected revenue if you do advertise, and the third, c, is the cost of advertising. You can assume that the input will follow these restrictions: -106 ≤ r, e ≤ 106 and 0 ≤ c ≤ 106.

    Output
    Output one line for each test case: “advertise”, “do not advertise” or “does not matter”, presenting whether it is most profitable to advertise or not, or whether it does not make any difference.

    Sample Input
    3
    0 100 70
    100 130 30
    -100 -70 40

    Sample Output
    advertise
    does not matter
    do not advertise

    嗯。。水题。。

    题意就是输入的:
    第一个数a是:做研发能赚多少钱,负数代表亏多少钱。
    第二个数b是:做广告能赚多少钱。
    第三个数c是:做广告的成本。
    也就是比较a和(b+c)谁大谁小,还是相等。
    如果a大:输出:do not advertise
    如果a小:输出:advertise
    如果一样大:输出:does not matter

    import java.util.Scanner;
    
    public class Main{
    
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            int t =sc.nextInt();
            while(t-->0){
                int a =sc.nextInt();
                int b =sc.nextInt();
                int c =sc.nextInt();
    
                if(a==(b-c)){
                    System.out.println("does not matter");
                }else if(a>(b-c)){
                    System.out.println("do not advertise");
                }else{
                    System.out.println("advertise");
                }
            }
        }
    }
    
  • 相关阅读:
    LOG4J介绍
    基于AspectJ的XML方式进行AOP开发
    tsdb import 相关
    xming + putty remote GUI
    html5 编辑
    swift container server 莫名stuck
    rsyslog trouble shooting
    文件处理 字符串处理
    list去掉重复元素
    找到字符串中最长的回文
  • 原文地址:https://www.cnblogs.com/webmen/p/5739207.html
Copyright © 2011-2022 走看看