zoukankan      html  css  js  c++  java
  • HDOJ(HDU) 2162 Add ‘em(求和)

    Problem Description
    Write a program to determine the summation of several sets of integers.

    Input
    The input file will consist of up to 250 sets of integers, where each set contains at most 100 integers and the integer values will be between –16000 and + 16000. Each set of numbers is started with the number of integers in the set, n. The next n input lines will each contain one integer of the set. You should stop processing when the size of the set, n, is<= 0.

    Output
    A single line of output should be generated for each set of integers. The line should have format shown below.

    Sample Input
    4
    -1
    3
    1
    1
    2
    19
    17
    5
    -645
    952
    -1488
    -5456
    -9342
    -1

    Sample Output
    Sum of #1 is 4
    Sum of #2 is 36
    Sum of #3 is -15979

    简单题,就是求和。

    import java.util.Scanner;
    
    public class Main{
    
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            int t=0;
            while(sc.hasNext()){
                int n =sc.nextInt();
                if(n==-1){
                    break;
                }
                long  sum=0;
                for(int i=0;i<n;i++){
                    long a = sc.nextLong();
                    sum+=a;
                }
                System.out.println("Sum of #"+(++t)+" is "+sum);
            }
        }
    }
    
  • 相关阅读:
    第二周作业
    查找整数
    第八周作业
    第七周作业
    第六周作业
    第五周作业
    第四周作业
    第三周作业
    第二周作业
    7-2求最大值及其下标
  • 原文地址:https://www.cnblogs.com/webmen/p/5739220.html
Copyright © 2011-2022 走看看