zoukankan      html  css  js  c++  java
  • HDOJ(HDU) 1673 Optimal Parking

    Problem Description
    When shopping on Long Street, Michael usually parks his car at some random location, and then walks to the stores he needs.
    Can you help Michael choose a place to park which minimises the distance he needs to walk on his shopping round?
    Long Street is a straight line, where all positions are integer.
    You pay for parking in a specific slot, which is an integer position on Long Street. Michael does not want to pay for more than one parking though. He is very strong, and does not mind carrying all the bags around.

    Input
    The first line of input gives the number of test cases, 1 <= t <= 100. There are two lines for each test case. The first gives the number of stores Michael wants to visit, 1 <= n <= 20, and the second gives their n integer positions on Long Street, 0 <= xi <= 99.

    Output
    Output for each test case a line with the minimal distance Michael must walk given optimal parking.

    Sample Input
    2
    4
    24 13 89 37
    6
    7 30 41 14 39 42

    Sample Output
    152
    70

    真心的题意难懂啊。。懂了之后就是大水题,大水题、、、

    题意:一条路上有n家商店,给出坐标。某人停车在某点后,要逛完所有商店回到车出。停车地点自选,求最少需要步行多远。

    无论停在那个商店,总要回来的,也就是说一定会是从最小坐标到最大坐标的距离的两倍!!!

    import java.util.Scanner;
    
    public class Main{
        public static void main(String[] args) {
            Scanner sc  = new Scanner(System.in);
            int t =sc.nextInt();
            while(t-->0){
                int n = sc.nextInt();
                int min=sc.nextInt();
                int max = min;
                int m;
                while(n-->1){
                    m = sc.nextInt();
                    if(m>max){
                        max=m;
                    }
                    if(m<min){
                        min=m;
                    }
                }
    
                System.out.println(2*(max-min));
    
            }
    
    
        }
    
    }
    
  • 相关阅读:
    在客户端判断上传文件大小(不支持opera)
    javascript冒泡排序(javascript算法学习)
    提高js性能方法(让js只判断一次)
    ie8本地预览报错的解决
    负载均衡获取客户端IP
    遍历变量里面所有的属性
    HttpWebrequest的使用
    C#调用EnyimMemcached
    MySQL国内省市直辖区
    Log4Net使用
  • 原文地址:https://www.cnblogs.com/webmen/p/5739283.html
Copyright © 2011-2022 走看看