zoukankan      html  css  js  c++  java
  • HDOJ 1194 Beat the Spread!(简单题)

    Problem Description
    Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores.

    Given the winning numbers for each type of bet, can you deduce the final scores?

    Input
    The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.

    Output
    For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing “impossible”. Recall that football scores are always non-negative integers.

    Sample Input
    2
    40 20
    20 40

    Sample Output
    30 10
    impossible

    题意:输入2个数 a,b。
    a是x,y的和,b是x,y的差。(x,y只能为正整数或者0)
    如果x,y中出现了负数就输出impossible。
    要注意的是x=(a+b)/2;y=(a-b)/2;
    因为x,y是正整数,所以(a+b)%2==0且(a-b)%2==0;

    import java.util.Scanner;
    
    public class Main{
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            int t = sc.nextInt();
            while(t-->0){
                int a = sc.nextInt();
                int b = sc.nextInt();
                int x=(a+b)/2;
                int y=(a-b)/2;
                if(x<0||y<0||(a+b)%2!=0||(a-b)%2!=0){
                    System.out.println("impossible");
                }else{
                    System.out.println(x+" "+y);
                }
            }
        }
    }
    
  • 相关阅读:
    生成新的密钥
    django 静态文件
    django 外键操作
    (fields.E130) DecimalFields must define a 'decimal_places' attribute.
    Django模型的Field Types总结
    Django 数据模型的字段列表整理
    需要学习的东西
    最全面的 MySQL 索引详解
    mysql 递归查询
    项目里面常用方法
  • 原文地址:https://www.cnblogs.com/webmen/p/5739331.html
Copyright © 2011-2022 走看看