zoukankan      html  css  js  c++  java
  • HDOJ 1020 Encoding

    Problem Description
    Given a string containing only ‘A’ - ‘Z’, we could encode it using the following method:

    1. Each sub-string containing k same characters should be encoded to “kX” where “X” is the only character in this sub-string.

    2. If the length of the sub-string is 1, ‘1’ should be ignored.

    Input
    The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only ‘A’ - ‘Z’ and the length is less than 10000.

    Output
    For each test case, output the encoded string in a line.

    Sample Input
    2
    ABC
    ABBCCC

    Sample Output
    ABC
    A2B3C

    题意:按照字符串的顺序,输出字符的个数和字符。
    如果字符出现次数为1次,只要输出原字符。
    如果输入为:ABBCCCBBB
    输出为:A2B3C3B
    而不是:A5B3C

    import java.util.Scanner;
    
    public class Main {
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            int t = sc.nextInt();
    
            while (t-- > 0) {
                String strs = sc.next();
                // System.out.println(strs+"=strs");
                boolean isSee[] = new boolean[strs.length()];
                for (int i = 1; i < isSee.length; i++) {
                    isSee[i] = false;
                }
                int sum = 0;
                boolean isLast=false;
                for (int i = 0; i < strs.length()-1; i++) {
                    if(strs.charAt(i)==strs.charAt(i+1)) {
                        isSee[i]=true;
                        isSee[i+1]=true;
                        sum=sum+1;
                    }else{
                        sum=sum+1;
                        isSee[i]=false;
                    }
    
                    if(!isSee[i]){
                        if(sum==1){
                            System.out.print(strs.charAt(i));
                        }else{
                            System.out.print(""+sum+strs.charAt(i));
                        }
                    }
    
                    if(!isSee[i]){
                        sum=0;
                    }
    
                }
    
                if(isSee[strs.length()-1]){
                    System.out.print(""+(sum+1)+strs.charAt(strs.length()-1));
                }else{
                    System.out.print(strs.charAt(strs.length()-1));
                }
                System.out.println();
            }
        }
    
    }
    
  • 相关阅读:
    聊聊用机器人做无人驾驶
    透过国外初创公司看高精度地图难题
    百度Apollo无人驾驶入门课程下载
    关于高精度地图定义的探讨
    camera理论基础和工作原理
    FPGA配置OV5640摄像头及RGB图像数据采集
    详细的摄像头模组工作原理!!!
    摄像头PIN脚功能作用
    详解摄像头各个引脚的作用关系
    Linux下UDP的组播接收和发送的简单例子
  • 原文地址:https://www.cnblogs.com/webmen/p/5739366.html
Copyright © 2011-2022 走看看