zoukankan      html  css  js  c++  java
  • HDOJ 1008 Elevator

    Problem Description
    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    Input
    There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

    Output
    Print the total time on a single line for each test case.

    Sample Input
    1 2
    3 2 3 1
    0

    Sample Output
    17
    41

    水题!
    电梯层数是可以输入重复的,并且重复的层数必须加5秒。
    大概题意:
    坐电梯,输入一个数n,接着是n个数,代表着楼层。
    然后电梯从0层出发,上楼每层需要6s,下楼每层需要4秒,每到一层需要
    停留5秒,问最后到达第(n个数)层后需要一共多少秒。最后的那层也要停留5秒才算。

    import java.util.Scanner;
    
    public class Main {
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            while(sc.hasNext()){
                int n=sc.nextInt();
                if(n==0){
                    break;
                }
                int a[] = new int[n];
                for(int i=0;i<n;i++){
                    a[i]=sc.nextInt();
                }
    
                int second = 0;
                for(int i=0;i<n;i++){
                    if(i==0){
                        second += a[i]*6;
                    }else{
                        if(a[i]>a[i-1]){
                            second= second+(a[i]-a[i-1])*6;
                        }
                        //题意是在同一层的还是要加5s
    //                  if(a[i]==a[i-1]){
    //                      second=second-5;
    //                  }
                        if(a[i]<a[i-1]){
                            second=second+(a[i-1]-a[i])*4;
                        }
                    }
                }
                second = second+n*5;
    
                System.out.println(second);
            }
        }
    
    }
    
  • 相关阅读:
    常用的Intent.Action(转)
    Android存储--SharedPreferences
    Linux虚拟机网络配置
    SSH的两种登录方式以及配置
    Docker学习のC/S模式
    Docker学习のDocker镜像
    Docker学习のDocker中部署静态页网站
    Docker学习のWindows下如何访问Docker本身的虚拟机
    Docker学习のDocker的简单应用
    Docker学习の更改Docker的目录
  • 原文地址:https://www.cnblogs.com/webmen/p/5739371.html
Copyright © 2011-2022 走看看