zoukankan      html  css  js  c++  java
  • poj3903 Stock Exchange 二分+dp

    题目地址:http://poj.org/problem?id=3903

    题目:

    Description

    The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for rising trends. Given a sequence of numbers p1, p2,...,pn representing stock prices, a rising trend is a subsequence pi1 < pi2 < ... < pik, with i1 < i2 < ... < ik. John’s problem is to find very quickly the longest rising trend.

    Input

    Each data set in the file stands for a particular set of stock prices. A data set starts with the length L (L ≤ 100000) of the sequence of numbers, followed by the numbers (a number fits a long integer). 
    White spaces can occur freely in the input. The input data are correct and terminate with an end of file.

    Output

    The program prints the length of the longest rising trend. 
    For each set of data the program prints the result to the standard output from the beginning of a line.

    Sample Input

    6 
    5 2 1 4 5 3 
    3  
    1 1 1 
    4 
    4 3 2 1

    Sample Output

    3 
    1 
    1

    Hint

    There are three data sets. In the first case, the length L of the sequence is 6. The sequence is 5, 2, 1, 4, 5, 3. The result for the data set is the length of the longest rising trend: 3.
     
     
    思路:dp入门水题。n^2的算法肯定会T的。所以只能用nlogn的算法;
      c【i】:表示长度为i的上升子序列的最后一个值(也是序列中的最大值);
      从左向右扫描题目所给的数组,然后在c数组中二分查找第一个大于a【i】的位置,然后更新c数组。最后c数组的大小就是最长上升子序列的长度。
      具体见代码吧,,没看懂的话可以看我dp分类里的另一个上升子序列的题目。讲的更详细。
    代码:
    #include <cstdlib>
    #include <cctype>
    #include <cstring>
    #include <cstdio>
    #include <cmath>
    #include <algorithm>
    #include <vector>
    #include <string>
    #include <iostream>
    #include <sstream>
    #include <map>
    #include <set>
    #include <queue>
    #include <stack>
    #include <fstream>
    #include <numeric>
    #include <iomanip>
    #include <bitset>
    #include <list>
    #include <stdexcept>
    #include <functional>
    #include <utility>
    #include <ctime>
    #define PB push_back
    #define MP make_pair
    using namespace std;
    typedef long long LL;
    typedef pair<int,int> PII;
    #define PI acos((double)-1)
    #define E exp(double(1))
    const int K=100000+9;
    int a[K],c[K];
    int main(void)
    {
        int n,cnt;
        while(cin>>n)
        {
            cnt=0;
            memset(c,0,sizeof(c));
            for(int i=1; i<=n; i++)
                scanf("%d",&a[i]);
            for(int i=1;i<=n;i++)
            {
                int d=lower_bound(c+1,c+1+cnt,a[i])-c;
                c[d]=a[i];
                cnt=max(cnt,d);
            }
            cout<<cnt<<endl;
        }
        return 0;
    }
  • 相关阅读:
    unset全局变量运用问题详解
    servlet
    windows 下 Eclipse+python开发环境配置
    连接mysql
    filter
    DotNetNuke 中文乱码问题的解决
    如何解决InfoPath的分页问题
    转:windows installer出错信息解决
    SQL中文全文搜索效果不理想问题的解决
    转:解决WEB页面上"焦点控制"一法
  • 原文地址:https://www.cnblogs.com/weeping/p/5782450.html
Copyright © 2011-2022 走看看