zoukankan      html  css  js  c++  java
  • 杭电1020-Encoding

    Problem Description
    Given a string containing only 'A' - 'Z', we could encode it using the following method:

    1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

    2. If the length of the sub-string is 1, '1' should be ignored.
     
    Input
    The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
     
    Output
    For each test case, output the encoded string in a line.
     
    Sample Input
    2
    ABC
    ABBCCC
     
    Sample Output
    ABC
    A2B3C
     
     
    #include <cstdlib>
    #include <iostream>
    #include <string>
    using namespace std;

    int main(int argc, char *argv[])
    {
        int n,len,num,i;
        cin>>n;
        string s;
        char temp;
        while(n--)
        {
           cin>>s;
           len=s.length();
           temp=s[0];
           num=1;;
           for(i=1;i<len;i++)
           {
             if(temp==s[i])
               num++;
             else
             {
                 if(num!=1)
                 cout<<num<<temp;
                 else
                 cout<<temp;
                 
                 num=1;
                 temp=s[i];
             }
           }
           if(num!=1)
              cout<<num<<temp;
           else
              cout<<temp;
           
           cout<<endl;
        }
        system("PAUSE");
        return EXIT_SUCCESS;
    }

  • 相关阅读:
    python(7)-pycharm mac和windows专业版安装破解
    Navicat Premium15激活 安装与激活(转载) 有效!!
    PHP 冒泡排序
    PHP 插入排序 -- 希尔排序
    PHP 插入排序 -- 折半查找
    PHP 插入排序 -- 直接插入排序
    PHP 哈夫曼的实现
    PHP call_user_func的一些用法和注意点
    PHP 组件注册的例子
    PHP 奇葩的debug_zval_dump的输出
  • 原文地址:https://www.cnblogs.com/wft1990/p/4330998.html
Copyright © 2011-2022 走看看