zoukankan      html  css  js  c++  java
  • POJ-1028 Web Navigation 和TOJ 1196. Web Navigation

    Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this.

    The following commands need to be supported:

    BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored.

    FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored.

    VISIT <url>: Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied.

    QUIT: Quit the browser.

    Assume that the browser initially loads the web page at the URL http://www.acm.org/

    Input

    Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.

    Output

    For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.

    Sample Input

    VISIT http://acm.ashland.edu/
    VISIT http://acm.baylor.edu/acmicpc/
    BACK
    BACK
    BACK
    FORWARD
    VISIT http://www.ibm.com/
    BACK
    BACK
    FORWARD
    FORWARD
    FORWARD
    QUIT
    

    Sample Output

    http://acm.ashland.edu/
    http://acm.baylor.edu/acmicpc/
    http://acm.ashland.edu/
    http://www.acm.org/
    Ignored
    http://acm.ashland.edu/
    http://www.ibm.com/
    http://acm.ashland.edu/
    http://www.acm.org/
    http://acm.ashland.edu/
    http://www.ibm.com/
    Ignored

    其中模拟上网访问(visit)网页的前进(FORWARD)和后退(BACK)。可以用两个栈,一个保存前进的网页URL,一个保存后退的URL。
    #include<iostream>
    #include<cstring>
    #include<stack>
    using namespace std;
    int main()
    {
        stack<string>Forward,Back;
        string order;
        string visit="http://www.acm.org/";
        while(cin>>order&&order!="QUIT")
        {
            if(order=="VISIT")
            {
                Back.push(visit);
                while(!Forward.empty())
                {
                    Forward.pop();
                }
                cin>>visit;    
            }
            else if(order=="BACK")
            {
                if(Back.empty())
                {
                    cout<<"Ignored"<<endl;
                    continue;
                }
                else
                {
                    Forward.push(visit);
                    visit=Back.top();
                    Back.pop();
                }
            }
            else if(order=="FORWARD")
            {
                if(Forward.empty())
                {
                    cout<<"Ignored"<<endl;
                    continue;
                }
                else
                {
                    Back.push(visit);
                    visit=Forward.top();
                    Forward.pop();
                }
            }
            else
            {
                cout<<"Invalid input"<<endl;
            }
            cout<<visit<<endl;
    
        }
        return 0;
    }
  • 相关阅读:
    推荐一本书 改善你的视力:跟眼镜说再见
    Gentoo中gcc4.1.2到gcc4.3.2的升级
    msbuild学习的一些相关链接
    SqlServer 2005安装问题
    Gentoo linux中安装php5运行环境
    sql 时间函数(全)
    asp.net中的对话框
    win7 资源管理器指向我的电脑
    C/C++ 位操作 总结
    【转】Java字节序转换
  • 原文地址:https://www.cnblogs.com/wft1990/p/6195552.html
Copyright © 2011-2022 走看看