zoukankan      html  css  js  c++  java
  • ZOJ-2965

    Accurately Say "CocaCola"!

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    In a party held by CocaCola company, several students stand in a circle and play a game.

    One of them is selected as the first, and should say the number 1. Then they continue to count number from 1 one by one (clockwise). The game is interesting in that, once someone counts a number which is a multiple of 7 (e.g. 7, 14, 28, ...) or contains the digit '7' (e.g. 7, 17, 27, ...), he shall say "CocaCola" instead of the number itself.

    For example, 4 students play this game. At some time, the first one says 25, then the second should say 26. The third should say "CocaCola" because 27 contains the digit '7'. The fourth one should say "CocaCola" too, because 28 is a multiple of 7. Then the first one says 29, and the game goes on. When someone makes a mistake, the game ends.

    During a game, you may hear a consecutive of p "CocaCola"s. So what is the minimum number that can make this situation happen?

    For example p = 2, that means there are a consecutive of 2 "CocaCola"s. This situation happens in 27-28 as stated above. 27 is then the minimum number to make this situation happen.

    Input

    Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 100) which is the number of test cases. And it will be followed by T consecutive test cases.

    There is only one line for each case. The line contains only one integer p (1 <= p <= 99).

    Output

    Results should be directed to standard output. The output of each test case should be a single integer in one line, which is the minimum possible number for the first of the p "CocaCola"s stands for.

    Sample Input

     

    2
    2
    3
    

     

    Sample Output

     

    27
    70
    题意:一群人玩过“7”的游戏,有7的数字或者7的倍数就要喊“cocacola”。给出一个数字p,求连续要喊“cocacola”p次的最小数字s;
    #include <bits/stdc++.h>
    using namespace std;
    int main()
    {
        int t,p,s;
        cin>>t;
        while(t--){
            cin>>p;
            if(p==1)
                s=7;
            else if(p==2)
                s=27;
            else if(p>2&&p<=10)
                s=70;
            else if(p==11)
                s=270;
            else if(p>11&&p<=100)
                s=700;
                cout<<s<<endl;
            
        }
        
        
        return 0;
    }

  • 相关阅读:
    星月教你做网站(HTML5+CSS+JS)----html背景知识 HTML5环境安装 创建HTML5文档1(结构)
    带你学C带你飞--16拾遗 17数组
    神经网络
    交互项回归与分组回归有什么差异?
    逻辑回归输出的值是真实的概率吗?
    逻辑回归
    机器学习中的核函数与核方法
    Regularization for Logistic Regression: L1, L2, Gauss or Laplace?
    What is Wrong with Linear Regression for Classification?What is Wrong with Linear Regression for Classification?
    感知器算法
  • 原文地址:https://www.cnblogs.com/whatiwhere/p/8596873.html
Copyright © 2011-2022 走看看