zoukankan      html  css  js  c++  java
  • [openjudge] 1455:An Easy Problem 贪心

    描述As we known, data stored in the computers is in binary form. The problem we discuss now is about the positive integers and its binary form.

    Given a positive integer I, you task is to find out an integer J, which is the minimum integer greater than I, and the number of '1's in whose binary form is the same as that in the binary form of I.

    For example, if "78" is given, we can write out its binary form, "1001110". This binary form has 4 '1's. The minimum integer, which is greater than "1001110" and also contains 4 '1's, is "1010011", i.e. "83", so you should output "83".输入One integer per line, which is I (1 <= I <= 1000000).

    A line containing a number "0" terminates input, and this line need not be processed.输出One integer per line, which is J.样例输入

    1
    2
    3
    4
    78
    0
    

    样例输出

    2
    4
    5
    8
    83

    普通的暴力可以过 比较慢就是了
    1的个数不变,那就找交换规律,其实只要从后向前找01子串交换,相当于进位了,再将后面的1依次放到末尾就行了
    #include <iostream>
    #include <stdio.h>
    #include <cstring>
    #include <string>
    using namespace std;
    
    int solve(int n)
    {
        int b[30], ans = 0;
        memset(b, 0, sizeof(b));
        int k = 0;
        while (n) {
            b[k++] = n % 2;
            n /= 2;
        }
        k++;
    
        int cnt = 0;
        for (int i = 0; i < k; i++) {
            if (b[i] && b[i+1]) {
                cnt++;
                b[i] = 0;
            }
            if (b[i] && !b[i+1]) {
                b[i] = 0;
                b[i+1] = 1;
                break;
            }
        }
        for (int j = 0; j < cnt; j++)
            b[j] = 1;
    
        for (int i = k; i >=0 ; i--) {
            ans = ans*2 + b[i];
        }
        return ans;
    }
    
    int main()
    {
        //freopen("1.txt", "r", stdin);
    
        int n;
        while (cin >> n && n) {
            cout << solve(n) << endl;
        }
    
    
        return 0;
    }


  • 相关阅读:
    关于ios6.0和5.0的横竖屏支持方法
    windows环境下搭建vue+webpack的开发环境
    诗歌类网址
    【第1阶段—GIS网址清单】其它杂项
    android内存指标
    Rownum与Order by
    使用反射复制一个JavaBean的对象
    catalog
    oralce中rownum理解
    BlockingQueue
  • 原文地址:https://www.cnblogs.com/whileskies/p/7190768.html
Copyright © 2011-2022 走看看