zoukankan      html  css  js  c++  java
  • Poj 2010-Moo University

    Moo University - Financial Aid
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 9046   Accepted: 2640

    Description

    Bessie noted that although humans have many universities they can attend, cows have none. To remedy this problem, she and her fellow cows formed a new university called The University of Wisconsin-Farmside,"Moo U" for short. 

    Not wishing to admit dumber-than-average cows, the founders created an incredibly precise admission exam called the Cow Scholastic Aptitude Test (CSAT) that yields scores in the range 1..2,000,000,000. 

    Moo U is very expensive to attend; not all calves can afford it.In fact, most calves need some sort of financial aid (0 <= aid <=100,000). The government does not provide scholarships to calves,so all the money must come from the university's limited fund (whose total money is F, 0 <= F <= 2,000,000,000). 

    Worse still, Moo U only has classrooms for an odd number N (1 <= N <= 19,999) of the C (N <= C <= 100,000) calves who have applied.Bessie wants to admit exactly N calves in order to maximize educational opportunity. She still wants the median CSAT score of the admitted calves to be as high as possible. 

    Recall that the median of a set of integers whose size is odd is the middle value when they are sorted. For example, the median of the set {3, 8, 9, 7, 5} is 7, as there are exactly two values above 7 and exactly two values below it. 

    Given the score and required financial aid for each calf that applies, the total number of calves to accept, and the total amount of money Bessie has for financial aid, determine the maximum median score Bessie can obtain by carefully admitting an optimal set of calves. 

    Input

    * Line 1: Three space-separated integers N, C, and F 

    * Lines 2..C+1: Two space-separated integers per line. The first is the calf's CSAT score; the second integer is the required amount of financial aid the calf needs 

    Output

    * Line 1: A single integer, the maximum median score that Bessie can achieve. If there is insufficient money to admit N calves,output -1. 

    Sample Input

    3 5 70
    30 25
    50 21
    20 20
    5 18
    35 30
    

    Sample Output

    35
    

    Hint

    Sample output:If Bessie accepts the calves with CSAT scores of 5, 35, and 50, the median is 35. The total financial aid required is 18 + 30 + 21 = 69 <= 70. 
    代码:
    #include<iostream>
    #include<cstdio>
    #include<queue>
    using namespace std;
    const int N=1e5+1;
    typedef pair<int,int> P;
    P a[N];
    int lower[N],upper[N];
    int main()
    {
        int n,c,f;
        cin>>n>>c>>f;
        int half=n/2;
        for(int i=0;i<c;i++)
        cin>>a[i].first>>a[i].second;
        sort(a,a+c);
        {
            int total=0;
            priority_queue<int>q;
            for(int i=0;i<c;i++)
            {
                lower[i]=q.size()==half?total:0x3f3f3f3f;
                q.push(a[i].second);
                total+=a[i].second;
                if(q.size()>half)
                {
                    total-=q.top();
                    q.pop();
                }
            }
        }
        {
            int total=0;
            priority_queue<int>q;
            for(int i=c-1;i>=0;i--)
            {
                upper[i]=q.size()==half?total:0x3f3f3f3f;
                q.push(a[i].second);
                total+=a[i].second;
                if(q.size()>half)
                {
                    total-=q.top();
                    q.pop();
                }
            }
        }
        for(int i=c-1;i>=0;i--)
        {
            if(a[i].second+upper[i]+lower[i]<=f)
            {
                cout<<a[i].first<<endl;
                return 0;
            }
        }
        cout<<-1<<endl;
        return 0;
    }
  • 相关阅读:
    JavaScript Patterns and Good Parts
    [Buzz Today]2012.05.015
    The first glance at Python
    The first glance at JavaScript
    [Buzz Today]2012.05.06
    vs.net2008 下 带完善后台管理的flash+js 轮显广告
    Vs.net2008 下 Ajaxpro 使用
    允许asp上传大文件的设置
    使用AutocompleteExtender无效或者没反应,输入啥都在webservice里面跟踪不到
    C#精髓 GridView 72般绝技
  • 原文地址:https://www.cnblogs.com/widsom/p/6731033.html
Copyright © 2011-2022 走看看