zoukankan      html  css  js  c++  java
  • hdu 1160 FatMouse's Speed (最长上升子序列+打印路径)

    Problem Description
    FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
     
    Input
    Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

    The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

    Two mice may have the same weight, the same speed, or even the same weight and speed. 
     
    Output
    Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

    W[m[1]] < W[m[2]] < ... < W[m[n]]

    and 

    S[m[1]] > S[m[2]] > ... > S[m[n]]

    In order for the answer to be correct, n should be as large as possible.
    All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 
     
    Sample Input
    6008 1300
    6000 2100
    500 2000
    1000 4000
    1100 3000
    6000 2000
    8000 1400
    6000 1200
    2000 1900
     
    Sample Output
    4
    4
    5
    9
    7
     
    主要是打印路径的一些小细节
     
    #include <cstdio>
    #include <map>
    #include <iostream>
    #include<cstring>
    #include<bits/stdc++.h>
    #define ll long long int
    #define M 6
    using namespace std;
    inline ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
    inline ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
    int moth[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
    int dir[4][2]={1,0 ,0,1 ,-1,0 ,0,-1};
    int dirs[8][2]={1,0 ,0,1 ,-1,0 ,0,-1, -1,-1 ,-1,1 ,1,-1 ,1,1};
    const int inf=0x3f3f3f3f;
    const ll mod=1e9+7;
    struct node{
        int w,s,id;
    };
    node p[1007];
    int dp[1007],path[1007];
    bool cmp1(node a,node b){
        if(a.w==b.w)
        return a.s>b.s;
        return a.w<b.w;
    }
    void output(int x){
        if(!x) return ;
        output(path[x]);
        cout<<p[x].id<<endl;
    }
    int main(){
        ios::sync_with_stdio(false);
        int ww,ss; int pos=1;
        while(cin>>ww>>ss){
            p[pos].w=ww; p[pos].s=ss;
            p[pos].id=pos;
            pos++;
        }
        sort(p+1,p+pos,cmp1);
        memset(dp,0,sizeof(dp));
        memset(path,0,sizeof(path));
        int ans1=-inf;
        int pp1=1;
        for(int i=1;i<pos;i++){
            int temp=0,jj=0;
            for(int j=1;j<i;j++){
                if(p[i].s<p[j].s&&p[i].w>p[j].w){
                    if(temp<dp[j]){
                        temp=dp[j];
                        jj=j;
                    }
                }
            }
            dp[i]=temp+1;path[i]=jj;
            if(ans1<dp[i]){
                ans1=dp[i];
                pp1=i;
            }
        }
        cout<<ans1<<endl;
        output(pp1);
    }
     
  • 相关阅读:
    批量修改数据后应收集统计信息
    this,this,再次讨论javascript中的this,超全面
    javascript中的闭包,超简单论述,保证小学生必懂
    有四中方法可以实现PHP的伪静态,你造吗?
    javascript 事件传播与事件冒泡,W3C事件模型
    浅谈asp.net性能
    div浮动层 兼容IE FF
    我们这些程序员
    c++学习笔记_1
    windows下hexo+github搭建个人博客
  • 原文地址:https://www.cnblogs.com/wmj6/p/10365639.html
Copyright © 2011-2022 走看看