zoukankan      html  css  js  c++  java
  • poj 1611 The Suspects(并查集输出集合个数)

    Description

    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
    Once a member in a group is a suspect, all members in the group are suspects. 
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

    Input

    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

    Output

    For each case, output the number of suspects in one line.

    Sample Input

    100 4

    2 1 2

    5 10 13 11 12 14

    2 0 1

    2 99 2

    200 2

    1 5

    5 1 2 3 4 5

    1 0

    0 0

    Sample Output

    4

    1

    1

    题意:有n个学生 共m组 现在问你有多少个人和第0个学生一个组(包括0自己)

    思路:并查集 并用一个数组记录当前节点下有多少子节点

    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<iostream>
    #include<string>
    #include<vector>
    #include<stack>
    #include<bitset>
    #include<cstdlib>
    #include<cmath>
    #include<set>
    #include<list>
    #include<deque>
    #include<map>
    #include<queue>
    #define ll long long int
    using namespace std;
    inline ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
    inline ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
    int moth[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
    int dir[4][2]={1,0 ,0,1 ,-1,0 ,0,-1};
    int dirs[8][2]={1,0 ,0,1 ,-1,0 ,0,-1, -1,-1 ,-1,1 ,1,-1 ,1,1};
    const int inf=0x3f3f3f3f;
    const ll mod=1e9+7;
    int n,m;
    int f[30007];
    ll sum[30007];
    int group[300007];
    int find(int x){
        if(x!=f[x])
            f[x]=find(f[x]);
        return f[x];
    }
    void join(int x,int y){
        int xx=find(x);
        int yy=find(y);
        if(xx!=yy){
            f[xx]=yy;
            sum[yy]+=sum[xx];
        }
            
    }
    int main(){
        ios::sync_with_stdio(false);
        while(cin>>n>>m){
            if(n==0&&m==0) break;
            for(int i=0;i<n;i++)
                f[i]=i,sum[i]=1;
            while(m--){
                int temp;
                cin>>temp;
                for(int i=1;i<=temp;i++)
                    cin>>group[i];
                for(int i=1;i<=temp-1;i++)
                    if(find(group[i])==0)
                        join(group[i+1],group[i]);
                    else if(find(group[i+1])==0)
                        join(group[i],group[i+1]);
                    else join(group[i+1],group[i]);
            }
            cout<<sum[0]<<endl;
        }
        return 0;
    }
  • 相关阅读:
    状态模式作业
    建造者模式作业
    关于 IIS 上的 Speech 设置
    装饰模式作业
    《软件架构与设计模式》关于 抽象工厂模式 的一个小例子
    谈一谈为什么我要创建个人博客
    C#网站发布在IIS10上,Access数据库读取为空白的解决方案
    广义表 Head Tail
    c# asp.net4.0尚未在web服务器上注册
    装饰者模式(例子)
  • 原文地址:https://www.cnblogs.com/wmj6/p/10466737.html
Copyright © 2011-2022 走看看