zoukankan      html  css  js  c++  java
  • hdu 2328 Corporate Identity(kmp)

    Problem Description
    Beside other services, ACM helps companies to clearly state their “corporate identity”, which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recently asked ACM for a help with their new identity. IBM do not want to change their existing logos and trademarks completely, because their customers are used to the old ones. Therefore, ACM will only change existing trademarks instead of creating new ones.

    After several other proposals, it was decided to take all existing trademarks and find the longest common sequence of letters that is contained in all of them. This sequence will be graphically emphasized to form a new logo. Then, the old trademarks may still be used while showing the new identity.

    Your task is to find such a sequence.
     
    Input
    The input contains several tasks. Each task begins with a line containing a positive integer N, the number of trademarks (2 ≤ N ≤ 4000). The number is followed by N lines, each containing one trademark. Trademarks will be composed only from lowercase letters, the length of each trademark will be at least 1 and at most 200 characters.

    After the last trademark, the next task begins. The last task is followed by a line containing zero.
     
    Output
    For each task, output a single line containing the longest string contained as a substring in all trademarks. If there are several strings of the same length, print the one that is lexicographically smallest. If there is no such non-empty string, output the words “IDENTITY LOST” instead.
     
    Sample Input
    3
    aabbaabb
    abbababb
    bbbbbabb
    2
    xyz
    abc
    0
     
    Sample Output
    abb
    IDENTITY LOST

    题意&思路:hdu 1238 数据的加强版 需要注意优化点已在代码处标记

    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<iostream>
    #include<string>
    #include<vector>
    #include<stack>
    #include<bitset>
    #include<cstdlib>
    #include<cmath>
    #include<set>
    #include<list>
    #include<deque>
    #include<map>
    #include<queue>
    #define ll long long int
    using namespace std;
    inline ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
    inline ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
    int moth[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
    int dir[4][2]={1,0 ,0,1 ,-1,0 ,0,-1};
    int dirs[8][2]={1,0 ,0,1 ,-1,0 ,0,-1, -1,-1 ,-1,1 ,1,-1 ,1,1};
    const int inf=0x3f3f3f3f;
    const ll mod=1e9+7;
    int n;
    string s[4007];
    int nextt[500];
    void getnext(string s){
        nextt[1]=0;
        int len=s.length();
        for(int i=2,j=0;i<=len;i++){
            while(j>0&&s[i-1]!=s[j]) j=nextt[j];
            if(s[i-1]==s[j]) j++;
            nextt[i]=j;
        }
    }
    bool kmp(string t,string p){
        int len1=p.length();
        int len2=t.length();
        for(int i=1,j=0;i<=len1;i++){
            while(j>0&&p[i-1]!=t[j]) j=nextt[j];
            if(p[i-1]==t[j]) j++;
            if(j==len2) return true;
        }
        return false;
    }
    int main(){
        ios::sync_with_stdio(false);
        while(cin>>n&&n){
            for(int i=0;i<n;i++)
                cin>>s[i];
            int len=s[0].length();
            string ans="";
            for(int i=len;i>=1;i--){
                for(int j=0;j<=len-i;j++){
                    string temp=s[0].substr(j,i);
                    getnext(temp);
                    bool f=1;
                    for(int k=0;k<n;k++)
                        if(!kmp(temp,s[k])){
                            f=0;
                            break;   //碰到假就弹出 
                        }
                    if(f){
                        if(ans.size()<temp.size()) ans=temp;
                        else if(ans.size()==temp.size()) ans=min(ans,temp);
                    }
                }
            }
            if(ans.size()<1) cout<<"IDENTITY LOST"<<endl;
            else cout<<ans<<endl;
                
        }
        return 0;
    }    
  • 相关阅读:
    二维数组
    ASCII_02_扩展
    ASCII_01
    【转】如何监控某个驱动器或目录及其下面的所有子目录的创建文件的动作
    webpack+vue2.0项目 (一) vue-cli脚手架
    分享两个常用的rem布局方式
    移动端border:1px问题解决方案
    sticky footer 布局
    用js数组实现最原始的图片轮播实现
    分享按钮(QQ,微信,微博等)移入动画效果
  • 原文地址:https://www.cnblogs.com/wmj6/p/10504938.html
Copyright © 2011-2022 走看看