zoukankan      html  css  js  c++  java
  • hdu 3709 Balanced Number(数位dp)

    Problem Description
    A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job
    to calculate the number of balanced numbers in a given range [x, y].
     
    Input
    The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 1018).
     
    Output
    For each case, print the number of balanced numbers in the range [x, y] in a line.
     
    Sample Input
    2
    0 9
    7604 24324
     
    Sample Output
    10
    897
     
    题意:求l~r之前的平衡数
    思路:枚举平衡点进行数位dp 注意每次枚举都会多算0 所以要减去多算的个数
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<iostream>
    #include<string>
    #include<vector>
    #include<stack>
    #include<bitset>
    #include<cstdlib>
    #include<cmath>
    #include<set>
    #include<list>
    #include<deque>
    #include<map>
    #include<queue>
    #define ll long long int
    using namespace std;
    inline ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
    inline ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
    int moth[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
    int dir[2][2]={1,0 ,0,1};
    int dirs[8][2]={1,0 ,0,1 ,-1,0 ,0,-1, -1,-1 ,-1,1 ,1,-1 ,1,1};
    const int inf=0x3f3f3f3f;
    int bits[20];
    ll dp[20][20][2000]; //位数 平衡点位置  左右两边的和的差 
    ll dfs(int len,int pos,int sum,bool ismax){
        if(!len) return sum==0; //如果左右相加为0就是平衡数 
        if(sum<0) return 0; //剪枝 
        if(!ismax&&dp[len][pos][sum]>=0) return dp[len][pos][sum];
        int up=ismax?bits[len]:9;
        ll cnt=0;
        for(int i=0;i<=up;i++){
            cnt+=dfs(len-1,pos,sum+(len-pos)*i,ismax&&i==up);
        }
        if(!ismax) dp[len][pos][sum]=cnt;
        return cnt;
    }
    ll solve(ll x){
        int len=0;
        while(x){
            bits[++len]=x%10;
            x/=10;
        }
        ll ans=0;
        for(int i=1;i<=len;i++){ //枚举分割点 
            ans+=dfs(len,i,0,true);
        }
        return ans-len-1;
    }
    int main(){
        ios::sync_with_stdio(false);
        int t;
        cin>>t;
        memset(dp,-1,sizeof(dp));
        while(t--){
            ll x,y; cin>>x>>y;
            cout<<solve(y)-solve(x-1)<<endl;
        }
        return 0;
    }
  • 相关阅读:
    摄像头置顶成品
    opencv鼠标事件
    opencvinpainting图像修复
    opencvdilate膨胀
    opencverode侵蝕
    opencvOTSU大津法—最大类间方差法
    opencvgetStructuringElement结构元素(内核矩阵)
    opencv时间
    IDEA在代码上无错误提示,但是编译时出现error:非法字符
    计算机端口号
  • 原文地址:https://www.cnblogs.com/wmj6/p/10816686.html
Copyright © 2011-2022 走看看