zoukankan      html  css  js  c++  java
  • hdu3123GCC

    Problem Description
    The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
    In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
    We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m
     
    Input
    The first line consists of an integer T, indicating the number of test cases.
    Each test on a single consists of two integer n and m.
     
    Output
    Output the answer of (0! + 1! + 2! + 3! + 4! + ... + n!)%m.

    Constrains
    0 < T <= 20
    0 <= n < 10^100 (without leading zero)
    0 < m < 1000000
     
    Sample Input
    1 10 861017
     
    Sample Output
    593846
     
    Source
     
    #include<iostream>
    #include<cstring>
    #include<cstdio>
    #include<cmath>
    
    using namespace std;
    
    char s[110000];
    
    int main()
    {
        long long t,n,md,a,i,sum,l;
        cin>>t;
        while(t--)
        {
            cin>>s>>md;
            l = strlen(s);
            n = 0;
            if(l>7)n = md;
            else
                for(i = 0;i<l;i++)
                    n = n*10+s[i]-'0';
            sum = a = 1;
            for(i = 1;i<=n;i++)
            {
                a = (a*i)%md;
                sum = (sum+a)%md;
            }
            sum%=md;
            cout<<sum<<endl;
        }
        return 0;
    }
  • 相关阅读:
    058_从键盘读取一个论坛积分,判断论坛用户等级
    057_统计 Linux 进程相关数量信息
    bzoj3436
    bzoj1202
    bzoj1044
    bzoj2338
    bzoj1854
    bzoj1856
    830C
    bzoj2132
  • 原文地址:https://www.cnblogs.com/wos1239/p/4564473.html
Copyright © 2011-2022 走看看