zoukankan      html  css  js  c++  java
  • POJ 1273 Drainage Ditches(网络流 最大流)

    Drainage Ditches
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 55893   Accepted: 21449

    Description

    Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
    Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
    Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

    Input

    The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

    Output

    For each case, output a single integer, the maximum rate at which water may emptied from the pond.

    Sample Input

    5 4
    1 2 40
    1 4 20
    2 4 20
    2 3 30
    3 4 10
    

    Sample Output

    50

    Source

    起始点1 汇点n
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<limits>
    #include<queue>
    #include<algorithm>
    using namespace std;
    int flow[205][205],a[205],f[205],mx[205][205];
    int n,m;
    void pre()
    {
        int u,v,value;
        memset(mx,0,sizeof(mx));
        for(int i=0;i<n;i++){
            cin>>u>>v>>value;
            mx[u][v]+=value;
        }
    }
    int solve()
    {
        int ans=0;
        memset(flow,0,sizeof(flow));
        queue<int> q;
        while(1){
            q.push(1);
            memset(a,0,sizeof(a));
            memset(f,0,sizeof(f));
            a[1]=INT_MAX;//每次都从起点出发
            while(!q.empty()){//每走一趟流 得到路径中最小的单条弧的流量 加入到总流量中
                int u=q.front();
                q.pop();
                for(int v=1;v<=m;v++){
                    if(!a[v]&&mx[u][v]>flow[u][v]){//如果前面的路径不为空 并且当前的最大容量仍然大于已经流过该条渠道的流量
                        a[v]=min(a[u],mx[u][v]-flow[u][v]);//选取最小的
                        f[v]=u;//将路径的父节点记录下来 方便更新流
                        q.push(v);//将可行的节点压入栈中
                    }
                }
                
            }
            if(!a[m]) return ans ;//如果找了一遍 最小的弧仍然是0 说明可行的流已经走完了
            for(int v=m;v!=1;v=f[v]){//不断找路径的父节点
                flow[f[v]][v]+=a[m];//将流量已经走过的 记录上去
                flow[v][f[v]]-=a[m];//反向的天上负
            }
            ans+=a[m];//将该条流的流量 即最小值 加上
        }
    }
    
    
    int main(void)
    {
        while(cin>>n>>m){
            pre();
            cout<<solve()<<endl;
        }
        return 0;
    }
  • 相关阅读:
    DRF 版本和认证
    DRF 视图和路由
    DRF 序列化组件
    RESTful
    Vuex以及axios
    npm、webpack、vue-cli
    Vue 生命周期
    Vue Router
    Vue 组件
    Vue 快速入门
  • 原文地址:https://www.cnblogs.com/woshijishu3/p/3905566.html
Copyright © 2011-2022 走看看